Project

General

Profile

Bug #8759

LKVOG filters out some modules even when there are explicitly set by a user

Added by Ilja Zakharov 10 months ago. Updated 3 months ago.

Status:
Closed
Priority:
Urgent
Assignee:
Category:
Program fragments generation
Target version:
Start date:
03/16/2018
Due date:
% Done:

0%

Estimated time:
Detected in build:
svn
Platform:
Published in build:

Description

For instance, LKVOG builds but filter outs all verification objects with such modules as net/bluetooth/bluetooth.ko. This is the main module of the subsystem and even when it is given by a user in "manual" strategy as a part of a group of modules, LKVOG does not generate required verification objects.

The issue should be studied more precisely and the fact that a user cannot add it using manual strategy should be definitely solved.

History

#1 Updated by Evgeny Novikov 6 months ago

  • Target version set to 2.0

2.0 will include many changes to LKVOG, let's fix this issue there as well.

#2 Updated by Evgeny Novikov 5 months ago

  • Assignee changed from Alexey Polushkin to Ilja Zakharov

#3 Updated by Ilja Zakharov 5 months ago

  • Status changed from New to Resolved

This is impossible by design now. The only issue when it is possible if a target fragment is not built at all.

#4 Updated by Evgeny Novikov 3 months ago

  • Status changed from Resolved to Closed

Branch klever-2.0 passed all tests and I merged it to master in 72be796e3 marked as v2.0rc1.

Also available in: Atom PDF