Project

General

Profile

Bug #9537

Frama-C (CIL) reports strange error about type redefinition

Added by Evgeny Novikov 8 months ago. Updated 8 months ago.

Status:
Closed
Priority:
Urgent
Start date:
03/13/2019
Due date:
% Done:

0%

Estimated time:
Detected in build:
svn
Platform:
Published in build:

Description

For the attached input source files Frama-C (CIL) fails with a strange error about type redefinition on the following command:

toplevel.opt "-no-autoload-plugins" "-no-findlib" "-c11" "-keep-logical-operators" "-remove-unused-inline-functions" "-remove-unused-static-functions" "-print" "-print-lines" "-no-print-annot" "-ocode" "cil.i" ".tmp_usb_invoke.abs-paths.trimmed.i" "atomic.abs-paths.trimmed.i" "dd.abs-paths.trimmed.i" "spi.abs-paths.trimmed.i" "test_model.bk.abs-paths.trimmed.i" "err.abs-paths.trimmed.i" "panic.abs-paths.trimmed.i" "common.abs-paths.trimmed.i" "slab.abs-paths.trimmed.i" "memory.abs-paths.trimmed.i" "gcc.abs-paths.trimmed.i" "nondet.abs-paths.trimmed.i" "reference memory.abs-paths.trimmed.i" "environment_model.abs-paths.trimmed.i" "bug kind funcs.trimmed.i" 


Files

fvtp.tar.gz (808 KB) fvtp.tar.gz Evgeny Novikov, 03/13/2019 10:16 AM

Related issues

Blocks Klever - Bug #6629: Used CIL is outdatedClosed03/13/2019

Actions

History

#1

Updated by Evgeny Novikov 8 months ago

  • Blocks Bug #6629: Used CIL is outdated added
#2

Updated by Mikhail Mandrykin 8 months ago

This was caused by clashes between anonymous composite type names due to bugs introduced by our (AstraVer) three-staged parsing (that enables recursive definitions and forward references in logic). Fixed in 55a1ad9c

#3

Updated by Mikhail Mandrykin 8 months ago

  • Status changed from New to Resolved
#4

Updated by Evgeny Novikov 8 months ago

Thank you, it helps! Please, close the issue.

#5

Updated by Mikhail Mandrykin 8 months ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF