Project

General

Profile

Bug #3362

Unhandled event loop exception при удалении требований с фрагментами

Added by Viktoria Kopach about 7 years ago. Updated about 6 years ago.

Status:
Closed
Priority:
High
Category:
-
Target version:
Start date:
08/27/2012
Due date:
% Done:

100%

Estimated time:
Detected in build:
0.14.167
Platform:
Windows x64
Published in build:
0.14.169

Description

1. В новом проекте создаем требование 01.
2. Импортируем документ.
3. В документе выделяем кусок текста и добавляем как фрагмент к новому требованию - подтребованию требования 01.
4. Удаляем требование 01.
Требования удаляются, но в Error log view появляется ошибка:

eclipse.buildId=M20120208-0800
java.version=1.7.0_02
java.vendor=Oracle Corporation
BootLoader constants: OS=win32, ARCH=x86, WS=win32, NL=ru_RU
Command-line arguments: -os win32 -ws win32 -arch x86

Error
Mon Aug 27 15:23:48 MSK 2012
Unhandled event loop exception

org.eclipse.swt.SWTException: Failed to execute runnable (java.lang.RuntimeException: node not found: 34c14e84-43a7-4937-ad97-1bbe4a0556cf)
at org.eclipse.swt.SWT.error(SWT.java:4282)
at org.eclipse.swt.SWT.error(SWT.java:4197)
at org.eclipse.swt.widgets.Synchronizer.runAsyncMessages(Synchronizer.java:138)
at org.eclipse.swt.widgets.Display.runAsyncMessages(Display.java:4140)
at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:3757)
at org.eclipse.ui.internal.Workbench.runEventLoop(Workbench.java:2701)
at org.eclipse.ui.internal.Workbench.runUI(Workbench.java:2665)
at org.eclipse.ui.internal.Workbench.access$4(Workbench.java:2499)
at org.eclipse.ui.internal.Workbench$7.run(Workbench.java:679)
at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:332)
at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Workbench.java:668)
at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.java:149)
at org.eclipse.ui.internal.ide.application.IDEApplication.start(IDEApplication.java:123)
at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:196)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:110)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:79)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:344)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:179)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
at java.lang.reflect.Method.invoke(Unknown Source)
at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:622)
at org.eclipse.equinox.launcher.Main.basicRun(Main.java:577)
at org.eclipse.equinox.launcher.Main.run(Main.java:1410)
Caused by: java.lang.RuntimeException: node not found: 34c14e84-43a7-4937-ad97-1bbe4a0556cf
at com.unitesk.requality.core.TreeDB.getNode(TreeDB.java:116)
at com.unitesk.requality.core.TreeNode.getParent(TreeNode.java:140)
at com.unitesk.requality.core.TreeNode.getQualifiedId(TreeNode.java:152)
at com.unitesk.requality.eclipse.views.properties.MainPropertySection.setTreeNode(MainPropertySection.java:154)
at com.unitesk.requality.eclipse.views.properties.TreeNodePropertiesTab$3.run(TreeNodePropertiesTab.java:136)
at org.eclipse.swt.widgets.RunnableLock.run(RunnableLock.java:35)
at org.eclipse.swt.widgets.Synchronizer.runAsyncMessages(Synchronizer.java:135)
... 22 more


Related issues

Related to Requality - Developer Request #3387: Непонятная проверка на nullClosed09/03/2012

Actions

History

#1

Updated by Alexey Khoroshilov about 7 years ago

  • Assignee set to Андрей Третьяков
  • Priority changed from Normal to High
  • Target version set to 0.14
#2

Updated by Андрей Третьяков about 7 years ago

  • Status changed from New to Resolved
  • % Done changed from 0 to 100

Applied in changeset r2989.

#3

Updated by Андрей Третьяков about 7 years ago

  • Published in build set to 0.14.169
#4

Updated by Viktoria Kopach about 7 years ago

  • Status changed from Resolved to Verified
  • Assignee changed from Андрей Третьяков to Alexey Khoroshilov
#5

Updated by Alexey Khoroshilov about 6 years ago

  • Status changed from Verified to Closed

Also available in: Atom PDF