Project

General

Profile

Actions

Системные требования

  • Операционная система Windows или Linux. Поддерживаются архитектуры x86 и x86-64. При использовании архитектуры x86 все нижеперечисленные программы также должны быть x86. При использовании x64 все используемые программы могут быть либо все x86, либо все x86-64. В настоящее время для Windows x86-64 нет поддерживаемого браузерного движка, интегрирующегося с Eclipse, поэтому на Windows x86-64 следует использовать только 32-битные версии программ.
  • Sun Java SE (рекомендуется версия 7.0, поддерживается 6.0 и выше)
  • Eclipse Platform (рекомендуется 3.7) Можно использовать минимальную сборку Platform Runtime Binary (около 50MB) или любой из пакетов на её основе.
    Для установки Eclipse достаточно распаковать архив в удобное место. При этом будет создан подкаталог 'eclipse'.
  • XULRunner 1.9.2.19. XULRunner Eclipse plugin: http://forge.ispras.ru/repo/xulrunner-eclipse/site/. Для Linux наряду с XULRunner поддерживается WebKit
  • Для командной работы с проектом также требуется установка Subversive, EGit или другой Eclipse Team Provider, в зависимости от используемой системы контроля версий. Рекомендуется EGit.
Зависимость Минимальная версия Рекомендуемая версия Windows x86, x86-64 Linux x86 Linux x86-64
Sun/Oracle Java SE 6.0 7.0 x86 x86 x86 или x86-64
Eclipse Platform 3.7.2 4.3.2 x86 x86 x86 или x86-64
XULRunner 1.9.2.19 1.9.2.19 x86 x86 x86 или x86-64

Подготовка к установке Requality

Шаг 1. Установка Eclipse

Для установки Eclipse достаточно распаковать архив в удобное место, при этом будет создан подкаталог eclipse.
Дальнейшие действия требуют знакомства с установкой плагинов Eclipse с использованием сайта обновления.

Шаг 2. Интеграция браузера в Eclipse

Requality требует интеграции браузерного движка с Eclipse. Поддерживаются XULRunner от Mozilla Foundation и WebKit.

ВНИМАНИЕ! После установки Requality рекомендуется проверить, успешно ли был установлен браузерный движок. Как это сделать читайте ниже в разделе "После установки".
ВНИМАНИЕ! На 64-битной версии Windows для использования XULRunner необходимо дополнительно установить Visual C++ 2010 runtime

Для Eclipse 4.4 на платформе Linux, в связи с несовместимостью Eclipse 4.4 и XULRunner необходимо использовать WebKit. Для его установки необходимо установить libwebkitgtk-1.0-0. Например, на Ubuntu/Debian для этого следует выполнить в командной строке команду:
sudo apt-get install libwebkitgtk-1.0-0

Для Eclipse 3.8 и выше для установки Mozilla XULRunner необходимо скачать подходящий вариант XULRunner 10.0.4, распаковать скачанный архив в удобное место на диске и дописать в конец eclipse.ini две строчки:
-Dorg.eclipse.swt.browser.DefaultType=mozilla
-Dorg.eclipse.swt.browser.XULRunnerPath=<path to XULRunner>

Например, если после распаковки скачанного архива ваш XULRunner лежит в папке C:\xulrunner, вторая строка должна будет выглядеть так:
-Dorg.eclipse.swt.browser.XULRunnerPath=C:\xulrunner

Для Eclipse 3.7 и ранее следуйте тем же инструкциям, но используйте XULRunner 1.9.2.19.

Шаг 3 (опциональный). Установка плагина для взаимодействия с системой контроля версий

Совместная работа над требованиями обеспечивается системой контроля версий. Следует убедиться, что в используемой среде Eclipse установлены плагины для взаимодействия с выбранной системой контроля версий: CVS, Subversion, git и т.п. При необходимости соответствующий плагин может быть установлен из репозитория Eclipse. Для работы с Subversion рекомендуется использовать плагин Subversive (плагин Subclipse не рекомендуется).

Установка Requality

Возможны два варианта установки инструмента: в каталог eclipse/dropins или через Eclipse Update Manager. Первый способ позволяет использовать инструмент как из Eclipse, так и в консольном режиме. Второй способ упрощает процесс обновления версии инструмента, но ограничивает использование только средой Eclipse.

1. Вариант установки через Eclipse Update Manager (update site)

  • Установка

Для установки Requality с помощью Eclipse Update Manager в оконном меню выберите пункт 'Install New Software...'

В открывшемся окне введите информацию о сайте обновления Requality.

Name: Requality
Location: http://forge.ispras.ru/repo/requality/site/

Далее выберите плагин Requality в списке доступных плагинов и продолжайте установку согласно указаниям мастера установки плагинов.

В процессе установки появится предупреждение о неподписанном содержании. Нажмите 'OK'.

После окончания установки Eclipse должен быть перезагружен.

  • Удаление

Для удаления плагина в оконном меню выберите пункт Help -> About Eclipse. В открывшемся окне 'About Eclipse' нажмите кнопку 'Installation Details'. В открывшемся окне 'Eclipse Installation Details' выберите нужный плагин - Requality, нажмите кнопку 'Uninstall' и продолжите удаление плагина согласно указаниям мастера удаления плагинов.
После окончания удаления Eclipse должен быть перезагружен.

  • Обновление

Для обновления Requality, установленного с помощью Eclipse Update Manager, в оконном меню выберите пункт Help -> Check for Updates. Дождитесь окончания процесса поиска обновлений. В открывшемся окне 'Available Updates' проверьте наличие обновления для плагина Requality. Если этот плагин есть в списке, отметьте его галочкой и продолжите установку обновления согласно указаниям мастера обновления плагинов.

Если плагина в списке нет, то возможные причины: либо данный плагин не установлен, либо используется последняя версия и новых обновлений нет.
После окончания обновления Eclipse должен быть перезагружен.

2. Вариант установки в dropins

  • Установка
    Для установки Requality распакуйте архив в каталог eclipse/dropins.
  • Удаление
    Запустите Eclipse, в которую установлен Requality. Установите любую перспективу, отличную от Requality. Закройте Eclipse.
    Удалите каталог с Requality из eclipse/dropins.
    Запустите Eclipse для обновления информации об установленных плагинах. Закройте Eclipse.
  • Обновление
    Удалите предыдущую версию Requality, а затем установите новую версию, как описано в пунктах 'Установка' и 'Удаление'.

После установки

После установки Requality нужно проверить, что браузер был успешно интегрирован с Eclipse.
Для этого нужно в главном меню Eclipse выбрать 'Window -> Preferences'. В 'Preferences' выбрать пункт 'Requality'. Справа вы увидите, какие браузеры интегрированы с 'Eclipse' и какой из них на данный момент активен (используется).

Чтобы изменить активный браузер, нужно кликнуть на поле 'Browser Engine' и в выпадающем списке выбрать желаемый. Далее следует сохранить изменения, нажав кнопку 'Apply'. При этом Eclipse должен быть перезапущен, чтобы изменения вступили в силу.
Если нужный браузер в выпадающем списке имеет статус 'not available', значит либо вы его не установили, либо установка прошла некорректно. Активирован может быть только тот браузер, который имеет статус 'available'.

Updated by Viktoria Kopach about 2 years ago · 1 revisions