Project

General

Profile

Bug #9844

Bash scripts that run side tools (EBMC, SymbiYosys, Verilog2SMV) can't extract names of several Verilog modules

Added by Sergey Smolov 8 months ago. Updated 8 months ago.

Status:
Rejected
Priority:
Normal
Assignee:
Category:
-
Start date:
10/02/2019
Due date:
% Done:

0%

Estimated time:
Detected in build:
master
Platform:
Published in build:

Description

Bash scripts for side tools (EBMC, SymbiYosys, Verilog2SMV) running unable to extract names of several Verilog modules:

/home/ssedai/projects/retrascope-mc-benchmark/src/main/bash/../benchmarks/texas97/PI_BUS/single_master/master2.v
/home/ssedai/projects/retrascope-mc-benchmark/src/main/bash/../benchmarks/texas97/PI_BUS/single_master/bus.v
/home/ssedai/projects/retrascope-mc-benchmark/src/main/bash/../benchmarks/texas97/PI_BUS/multi_master/master2.v
/home/ssedai/projects/retrascope-mc-benchmark/src/main/bash/../benchmarks/texas97/PI_BUS/multi_master/bus.v
/home/ssedai/projects/retrascope-mc-benchmark/src/main/bash/../benchmarks/texas97/PPC60X_bus/src/cpu.v
/home/ssedai/projects/retrascope-mc-benchmark/src/main/bash/../benchmarks/texas97/PPC60X_bus/src/arbiter.v
/home/ssedai/projects/retrascope-mc-benchmark/src/main/bash/../benchmarks/texas97/PPC60X_bus/src/mem.v
/home/ssedai/projects/retrascope-mc-benchmark/src/main/bash/../benchmarks/verilog2smv/VCEGAR/pi_bus/pi_bus.v
/home/ssedai/projects/retrascope-mc-benchmark/src/main/bash/../benchmarks/verilog2smv/VCEGAR/zaher/zdlx_impl.v_for_pred.v
/home/ssedai/projects/retrascope-mc-benchmark/src/main/bash/../benchmarks/verilog2smv/VIS/Miim/vMiim_p2.v
/home/ssedai/projects/retrascope-mc-benchmark/src/main/bash/../benchmarks/verilog2smv/VIS/Miim/vMiim_p1.v
/home/ssedai/projects/retrascope-mc-benchmark/src/main/bash/../benchmarks/vcegar/miim/vMiim.v
/home/ssedai/projects/retrascope-mc-benchmark/src/main/bash/../benchmarks/vcegar/pi_bus/main_1.v

For these modules their top level names are empty. Note, that all the scripts have a precondition: top level name is it's first declared module name.

The problem is in the following code:

top_name=$(echo "${line}" | sed -n 's/^module \([a-zA-Z0-9_]*\)[ |(||;].*$/\1/p')

History

#1

Updated by Sergey Smolov 8 months ago

  • Status changed from New to Rejected

Ticket is moved to hdl-benchmarks project

Also available in: Atom PDF