Project

General

Profile

Bug #9660

Repository: после первого сохранения с репозиторий версия становится 0*

Added by Viktoria Kopach about 1 year ago. Updated about 2 months ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Start date:
05/20/2019
Due date:
% Done:

100%

Estimated time:
Detected in build:
1.1.566
Platform:
Windows x64
Published in build:
1.1.572

Description

1. Создаем требование. Видим, что версия у него - 0*.
2. Сохраняем изменения в репозиторий.
Видим, что версия у этого требования так и осталась 0*.

History

#1

Updated by Alexey Khoroshilov about 1 year ago

  • Target version set to 1.1 (stable)
#2

Updated by Viktoria Kopach about 1 year ago

На другом проекте не воспроизвелось.
В описанной в данном тикете ситуации было создано требование, изменения опубликованы в репозиторий, и на другом воркспейсе получено обновление. И после этого это требование везде имело версию 0*. И при дальнейших локальных изменениях она так и оставалась 0*.
При следующей попытке что-то сделать с репозиторием возникла ошибка, описанная в https://forge.ispras.ru/issues/9661.
Так что возможно исходная проблема случилась раньше, а описанное в тикете - последствия. Как воспроизвести - пока не понятно.

#3

Updated by Denis Kildishev about 1 year ago

да, связано с той проблемой с версионированием

#4

Updated by Denis Kildishev about 1 year ago

У меня пока ни разу не воспроизвелось, похоже это было по причине той ошибки

#5

Updated by Denis Kildishev about 1 year ago

  • Published in build set to 1.1.572
  • % Done changed from 0 to 100
  • Status changed from New to Resolved
#6

Updated by Viktoria Kopach about 1 year ago

  • Status changed from Resolved to Verified
#7

Updated by Alexey Khoroshilov about 2 months ago

  • Status changed from Verified to Closed

Also available in: Atom PDF