Project

General

Profile

Bug #9483

Support external function declarations without parameters

Added by Ilya Shchepetkov 3 months ago. Updated 2 months ago.

Status:
Closed
Priority:
Urgent
Category:
C back-end
Start date:
02/11/2019
Due date:
% Done:

0%

Estimated time:
Detected in build:
svn
Platform:
Published in build:

Description

Aspect:

info: declare_func($ $(..)) {
    $fprintf<"declare_func.txt","%s\n",$signature>
}

Code:

extern char *get_parent_id();

Result:

char *get_parent_id(/* LDV: ../../aspectator/gcc/c-family/ldv-pretty-print.c: 1552: parameter type list of direct declarator was not printed */);

History

#1

Updated by Evgeny Novikov 3 months ago

  • Priority changed from Normal to Urgent
  • Category set to C back-end
  • Subject changed from Remove warnings from info request output to Support external function declarations without parameters

Although in this particular case removing comment will help, but in other cases there may be serious issues. Thus, instead of suppressing warnings let's fix issues!

#2

Updated by Evgeny Novikov 3 months ago

  • Status changed from New to Resolved

I fixed the issue in 589072b. Please, confirm that the issue is gone.

#3

Updated by Evgeny Novikov 3 months ago

  • Status changed from Resolved to Closed

I suggest that everything is great.

#4

Updated by Ilya Shchepetkov 2 months ago

Not that great as it should be. The error is a little bit different though, and it occurs only in 15 function declarations (of 230 000).

/* LDV: ../../aspectator/gcc/c-family/ldv-pretty-print.c: 4121: type specifier was not printed */ strtof32(char const *restrict, char **restrict);

Can't reopen the issue myself.

#5

Updated by Evgeny Novikov 2 months ago

Ilya Shchepetkov wrote:

Not that great as it should be. The error is a little bit different though, and it occurs only in 15 function declarations (of 230 000).

/* LDV: ../../aspectator/gcc/c-family/ldv-pretty-print.c: 4121: type specifier was not printed */ strtof32(char const *restrict, char **restrict);

Can't reopen the issue myself.

This is completely another issue since it is related with return type rather than with parameters. Please, open it and provide an example. I guess that corresponding C files do not belong to the kernel or modules since, e.g. strtof32 comes from GLIBC. So the priority will not very high.

Also available in: Atom PDF