Project

General

Profile

Feature #9413

Set total verdict and total similarity more precisely on base of automatic marks association

Added by Ilja Zakharov about 2 years ago. Updated 10 days ago.

Status:
Rejected
Priority:
Urgent
Category:
Bridge
Target version:
Start date:
12/12/2018
Due date:
% Done:

0%

Estimated time:
Published in build:

Description

Currently on the page with all unsafes total similarity is caclulated as an average value. In practice if I see 0% unsafe mark and 100% safe mark I see 50% incompatible marks.
There are the following proposals:
  • Calculate total similarity as a maximum.
  • Prevent incompatible marks setting and total similarity recalculation if there is at least one manually confirmed mark exists for this error trace.
  • Do not consider 0% marks calculating total verdict to prevent useless incompatible marks label.

Related issues

Is duplicate of Klever - Feature #9412: Support more advanced calculation of total verdicts and similarityClosed12/12/201807/10/2019

Actions

History

#1

Updated by Ilja Zakharov about 2 years ago

  • Related to Feature #9412: Support more advanced calculation of total verdicts and similarity added
#2

Updated by Evgeny Novikov about 2 years ago

I think that if we will agree to implement #9412 in another way, this issue will gone. BTW, it demonstrates other problems when "external" marks can lead to unplesant statistics.

One more observation, I already suggested somewhere to calculate a total similarity as a maximum, but then I thought more and decided that the current way is better. Indeed, it can help to detect mark duplicates when some mark patterns catch error traces but similarities are not 100%. Sometimes, even fewer similarities are okay and one can delete extra marks with 100% similarity. Besides, you can find "bad" marks with <100% similarity and remove them since new marks match error traces better.

#3

Updated by Evgeny Novikov about 2 years ago

  • Related to deleted (Feature #9412: Support more advanced calculation of total verdicts and similarity)
#4

Updated by Evgeny Novikov about 2 years ago

  • Is duplicate of Feature #9412: Support more advanced calculation of total verdicts and similarity added
#5

Updated by Evgeny Novikov about 2 years ago

  • Status changed from New to Rejected

This is included into #9412 now.

#6

Updated by Evgeny Novikov 10 days ago

  • Subject changed from Set total verdict and total similarity more precisely on base of automatic marks assotiation to Set total verdict and total similarity more precisely on base of automatic marks association

Also available in: Atom PDF