Project

General

Profile

Bug #9369

Update production silently ignores wrong directory name

Added by Vadim Mutilin 4 months ago. Updated 4 months ago.

Status:
Open
Priority:
Urgent
Category:
Deployment
Target version:
Start date:
11/08/2018
Due date:
% Done:

0%

Estimated time:
Detected in build:
svn
Platform:
Linux x64
Published in build:

Description

If I put wrong directory name in "Klever build bases"
update production command does not report any errors.

sudo klever/deploys/bin/deploy-local --deployment-directory klever-inst/ update production
debian@mutilin-klever-md:~$ sudo klever/deploys/bin/deploy-local --deployment-directory klever-inst/ update production2018-11-08 09:57:28 (__init__.py:058) INFO> Start execution of action "update" for Klever "production" 
2018-11-08 09:57:28 (utils.py:045) INFO> Execute command "git ls-remote --refs /home/debian/klever" 
2018-11-08 09:57:28 (utils.py:138) INFO> "Klever" is up to date (version: "f90b3835a1ea7226cbf729449edd63253209e097")
2018-11-08 09:57:28 (utils.py:045) INFO> Execute command "git ls-remote --refs https://forge.ispras.ru/attachments/download/5827/cil-1.5.1.tar.gz" 
2018-11-08 09:57:28 (utils.py:138) INFO> "CIL" is up to date (version: "1.5.1-ldv")
2018-11-08 09:57:28 (utils.py:045) INFO> Execute command "git ls-remote --refs https://forge.ispras.ru/attachments/download/6006/cif-ca9075.tar.gz" 
2018-11-08 09:57:29 (utils.py:138) INFO> "CIF" is up to date (version: "ca9075")
2018-11-08 09:57:29 (utils.py:045) INFO> Execute command "git ls-remote --refs https://releases.hashicorp.com/consul/0.9.2/consul_0.9.2_linux_amd64.zip" 
2018-11-08 09:57:29 (utils.py:138) INFO> "Consul" is up to date (version: "0.9.2")
2018-11-08 09:57:29 (utils.py:045) INFO> Execute command "git ls-remote --refs https://forge.ispras.ru/attachments/download/5828/CPAchecker-1.7-svn 27946-unix.tar.gz" 
2018-11-08 09:57:30 (utils.py:138) INFO> "CPAchecker" is up to date (version: "trunk:27946")
2018-11-08 09:57:30 (__init__.py:075) INFO> Finish execution of action "update" for Klever "production" 
klever-debian-wrongpath.json (1.93 KB) klever-debian-wrongpath.json Vadim Mutilin, 11/08/2018 01:12 PM

History

#2 Updated by Vadim Mutilin 4 months ago

I found that the problem is that if I put small letters "Klever build bases", instead of "Klever Build Bases" the section is silently ignored

#3 Updated by Evgeny Novikov 4 months ago

  • Status changed from New to Rejected

Vadim Mutilin wrote:

I found that the problem is that if I put small letters "Klever build bases", instead of "Klever Build Bases" the section is silently ignored

Of course, this is expected behavior. We use it often to introduce some auxiliary configuration sections that should not be treated.

#4 Updated by Vadim Mutilin 4 months ago

In this case the file should not be edited by Klever users, because the user can not understand what is written wrong.

#5 Updated by Evgeny Novikov 4 months ago

  • Priority changed from High to Urgent
  • Assignee set to Evgeny Novikov
  • Status changed from Rejected to Open

Okay, let's avoid this undocumented behavior and check for presence just of some subset of predefined sections in deployment configurations.

Also available in: Atom PDF