Project

General

Profile

Bug #9367

Misleading message in the error description

Added by Vadim Mutilin about 1 month ago. Updated about 1 month ago.

Status:
Open
Priority:
Urgent
Category:
Infrastructure of Core
Target version:
Start date:
11/07/2018
Due date:
% Done:

0%

Estimated time:
Detected in build:
svn
Platform:
Published in build:

Description

I run validation set. I've got an exception:
File "/home/debian/klever-inst/klever/core/core/job.py", line 518, in __set_build_base raise FileExistsError('Build base "{0}" is not a directory'.format(build_base)) FileExistsError: Build base "/home/debian/klever-inst/klever/build bases/validation/7ce77510c9c7~" is not a directory
How this directory should be created?

History

#1 Updated by Evgeny Novikov about 1 month ago

  • Status changed from New to Rejected

This is not a bug at all. Redmine should not be used to ask such the questions.

#2 Updated by Vadim Mutilin about 1 month ago

It was a question initially, but after finding a solution, I realized that the error message was misleading rather than helpful. The correct explanation should talk about wrong configuration of Job (job.json) (better to warn about exact field) or wrong configuration of Klever deployment (klever.json) (better saying what is missing there).

#3 Updated by Evgeny Novikov about 1 month ago

  • Target version set to 2.1
  • Priority changed from High to Urgent
  • Assignee set to Evgeny Novikov
  • Status changed from Rejected to Open
  • Category changed from Bridge to Infrastructure of Core

Okay, let's fix the error message. This is trivially.

Also available in: Atom PDF