Project

General

Profile

Feature #9348

Request for changes in jobs and tasks just after receiving corresponding notifications

Added by Evgeny Novikov over 1 year ago. Updated 5 months ago.

Status:
Closed
Priority:
Urgent
Assignee:
Category:
Scheduling
Target version:
Start date:
10/25/2018
Due date:
% Done:

0%

Estimated time:
Published in build:

Description

See description of #9347.


Related issues

Blocked by Klever - Feature #9347: Notify schedulers about changes in jobs and tasksClosed10/25/201807/02/2019

Actions

History

#1

Updated by Evgeny Novikov over 1 year ago

  • Blocked by Feature #9347: Notify schedulers about changes in jobs and tasks added
#2

Updated by Evgeny Novikov about 1 year ago

  • Assignee changed from Ilja Zakharov to Evgeny Novikov

Ilja is occupied for 1-2 weeks while we need this ASAP to move forward (until schedulers will switch to the new interface for receiving notifications on new jobs and tasks, I can't switch other components responsible for their decision).

#3

Updated by Evgeny Novikov about 1 year ago

  • Assignee changed from Evgeny Novikov to Ilja Zakharov

Unfortunately, the current implementation of interconnections between Bridge, schedulers and workers is very large and complicated. I suggest to simplify it as much as possible to avoid numerous tricky issues that we have had to fix often. So, a rather considerable part of schedulers and workers should be re-implemented. I started the job in branch bridge-2.1. It should be completed by the primary author.

#4

Updated by Evgeny Novikov about 1 year ago

I renamed branch to bridge-3.0.

#5

Updated by Evgeny Novikov 11 months ago

I guess that the issue is solved in branch scheduler-klever-3, isn't it? Did you clean up configuration files from old stuff?

#6

Updated by Ilja Zakharov 7 months ago

  • Status changed from New to Resolved

This was implemented and lives in klever-3.0 branch currently.

#7

Updated by Evgeny Novikov 5 months ago

  • Status changed from Resolved to Closed

In master.

Also available in: Atom PDF