Project

General

Profile

Bug #9082

Remove tag does not work

Added by Anton Vasilyev about 1 year ago. Updated about 1 year ago.

Status:
Closed
Priority:
Immediate
Category:
Bridge
Target version:
Start date:
07/10/2018
Due date:
% Done:

0%

Estimated time:
Detected in build:
svn
Platform:
Published in build:

Description

Tag remove opens confirmation dialogue,
But on "Remove" button of confirmation "Are you sure? All children of the selected tag will be also removed!" it shows "Ajax request error. Maybe connection refused." and doesn't perform tag removal.

History

#1

Updated by Evgeny Novikov about 1 year ago

  • Target version set to 1.1
  • Priority changed from Normal to Immediate

I think that is caused by moving to Django 2+, so, this is a crucial regression to be fixed ASAP.

#2

Updated by Vladimir Gratinskiy about 1 year ago

It can be fixed by replacing "$.ajax" with "$.post" in "bridge/marks/static/marks/js/tagsmap.js" line 92.

#3

Updated by Evgeny Novikov about 1 year ago

  • Assignee changed from Evgeny Novikov to Vladimir Gratinskiy
  • Status changed from New to Feedback

Let's Anton will test this.

#4

Updated by Anton Vasilyev about 1 year ago

Works with replacing "$.ajax" with "$.post"

#5

Updated by Evgeny Novikov about 1 year ago

  • Status changed from Feedback to Closed

I made the suggested fix in 28d6a638 to master and backported it to v1.0-stable.

Also available in: Atom PDF