Project

General

Profile

Bug #9081

Uploading unsafe marks fail with unknown error

Added by Evgeny Novikov over 1 year ago. Updated 3 months ago.

Status:
Resolved
Priority:
High
Category:
Bridge
Target version:
Start date:
07/10/2018
Due date:
07/11/2019
% Done:

100%

Estimated time:
Detected in build:
svn
Platform:
Published in build:

Description

For instance, try to upload the attached unsafe marks. There isn't any error messages in any log files.

In ideal all new marks from the archive attached to #9080 should be uploaded without any errors. When uploading them there are plenty exceptions like:

Traceback (most recent call last):
  File "/home/novikov/work/klever/bridge/marks/Download.py", line 249, in __upload_all
    mark_type = UploadMark(self.user, fp).type
  File "/home/novikov/work/klever/bridge/marks/Download.py", line 159, in __init__
    self.mark = self.__upload_mark(archive)
  File "/home/novikov/work/klever/bridge/marks/Download.py", line 203, in __upload_mark
    version['tags'] = list(tags_in_db[tname] for tname in version['tags'])
  File "/home/novikov/work/klever/bridge/marks/Download.py", line 203, in <genexpr>
    version['tags'] = list(tags_in_db[tname] for tname in version['tags'])
KeyError: 'Patch'

Perhaps these exceptions also happen when uploading individual marks.

Most likely this is one more crucial regression to be fixed ASAP and backported to v1.0-stable, since before we didn't encounter such the errors.

History

#1

Updated by Vladimir Gratinskiy over 1 year ago

The problem is there are no tags in the DB for marks. I can just create them at the root while uploading, but it is wrong. The tree structure of tags isn't saved in marks' archives.

#2

Updated by Evgeny Novikov over 1 year ago

Vladimir Gratinskiy wrote:

The problem is there are no tags in the DB for marks. I can just create them at the root while uploading, but it is wrong. The tree structure of tags isn't saved in marks' archives.

Thus, it seems that this issue exists forever, is it?

And what is the right way to move marks from Bridge A to Bridge B? Should one download and upload all tags in advance?

#3

Updated by Vladimir Gratinskiy over 1 year ago

Evgeny Novikov wrote:

Vladimir Gratinskiy wrote:

The problem is there are no tags in the DB for marks. I can just create them at the root while uploading, but it is wrong. The tree structure of tags isn't saved in marks' archives.

Thus, it seems that this issue exists forever, is it?

Right.

And what is the right way to move marks from Bridge A to Bridge B? Should one download and upload all tags in advance?

If Bridge B doesn't have unique tags then yes. Otherwise user should create tags one by one before marks uploading.

#4

Updated by Vladimir Gratinskiy over 1 year ago

Vladimir Gratinskiy wrote:

And what is the right way to move marks from Bridge A to Bridge B? Should one download and upload all tags in advance?

If Bridge B doesn't have unique tags then yes.

Sorry, I thought that tags are deleted before uploading new (like marks). But they aren't. So you can just upload new tags tree for marks.

#5

Updated by Evgeny Novikov over 1 year ago

  • Target version deleted (1.1)
  • Priority changed from Immediate to High

So, let's print a normal error message rather than "Unknown error" one day.

Discussion about tags downloading/uploading should be moved away.

#6

Updated by Vladimir Gratinskiy 3 months ago

  • % Done changed from 0 to 100
  • Status changed from New to Resolved
  • Due date set to 07/11/2019

Already fixed in bridge-3.0.

#7

Updated by Evgeny Novikov 3 months ago

  • Target version set to 3.0

Also available in: Atom PDF