Project

General

Profile

Bug #9068

Error trace simplification causes an exception

Added by Pavel Andrianov about 2 years ago. Updated 7 months ago.

Status:
Rejected
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Start date:
07/05/2018
Due date:
% Done:

0%

Estimated time:
Detected in build:
svn
Platform:
Published in build:

Description

Removing tmp vars tries to remove edge with warning tag:
Raise exception:
Traceback (most recent call last):
File "/home/debian/klever-inst/klever/core/core/components.py", line 428, in run
self.main()
File "/home/debian/klever-inst/klever/core/core/components.py", line 332, in callbacks_caller
ret = attr(*args, **kwargs)
File "/home/debian/klever-inst/klever/core/core/vrp/__init__.py", line 246, in fetcher
raise self.__exception
File "/home/debian/klever-inst/klever/core/core/vrp/__init__.py", line 358, in process_single_verdict
get_error_trace_id=True)
File "/home/debian/klever-inst/klever/core/core/components.py", line 332, in callbacks_caller
ret = attr(*args, **kwargs)
File "/home/debian/klever-inst/klever/core/core/vrp/__init__.py", line 259, in process_witness
error_trace = import_error_trace(self.logger, witness)
File "/home/debian/klever-inst/klever/core/core/vrp/et/__init__.py", line 33, in import_error_trace
generic_simplifications(logger, trace)
File "/home/debian/klever-inst/klever/core/core/vrp/et/tmpvars.py", line 23, in generic_simplifications
_basic_simplification(logger, trace)
File "/home/debian/klever-inst/klever/core/core/vrp/et/tmpvars.py", line 35, in _basic_simplification
error_trace.remove_edge_and_target_node(edge)
File "/home/debian/klever-inst/klever/core/core/vrp/et/error_trace.py", line 228, in remove_edge_and_target_node
raise ValueError('Cannot delete edge with warning: {!r}'.format(edge['source']))
KeyError: 'source'


Files

History

#1

Updated by Evgeny Novikov about 2 years ago

Please, provide some statistics to understand whether the issue is important for you. If not, we will postpone it until great upcoming changes in witness creating, processing and visualization.

#2

Updated by Pavel Andrianov about 2 years ago

I have no reliable sttistics, as Klever stops after the first failure. Anyway, about ten modules were analized correctly before the failure, so, seems, this case is not very often, so it can be postponed.

#3

Updated by Evgeny Novikov 7 months ago

  • Status changed from New to Rejected

I guess that the issue is not relevant anymore since we completely changed the witness processor regarding sources.

Also available in: Atom PDF