Project

General

Profile

Bug #9056

Exception when packages are not specified in configuration

Added by Pavel Andrianov 8 months ago. Updated 8 months ago.

Status:
Closed
Priority:
Immediate
Category:
Deployment
Target version:
Start date:
07/02/2018
Due date:
% Done:

0%

Estimated time:
Detected in build:
svn
Platform:
Published in build:

Description

If section 'packages' is missed in configuration file, there is an exception

Traceback (most recent call last):
File "./deploys/install_deps.py", line 136, in <module>
main()
File "./deploys/install_deps.py", line 129, in main
args.update_python3_packages)
File "./deploys/install_deps.py", line 42, in install_deps
new_pckgs = get_pckgs(deploy_conf['Packages'])
KeyError: 'Packages'

History

#1 Updated by Evgeny Novikov 8 months ago

  • Target version set to 1.0
  • Priority changed from Normal to Immediate
  • Assignee set to Evgeny Novikov
  • Category set to Deployment

This may be treated as a regression since in 0.2 deployment scripts included package lists and disallowed to configure them.

#2 Updated by Evgeny Novikov 8 months ago

  • Status changed from New to Closed

I added two more checks, so that now there are appropriate error messages rather than exception. I tested installation since changes touch just it, but skipped the rest of testing. The commit to master is a9583c04.

Also available in: Atom PDF