Project

General

Profile

Bug #9054

Exception when ssh-key is not specified

Added by Pavel Andrianov 8 months ago. Updated 8 months ago.

Status:
Closed
Priority:
Immediate
Category:
Deployment
Target version:
Start date:
07/02/2018
Due date:
% Done:

0%

Estimated time:
Detected in build:
svn
Platform:
Published in build:

Description

Command line: ./deploys/bin/deploy-openstack --os-username andrianov update 'Klever developer instance'
Traceback (most recent call last):
File "./deploys/bin/deploy-openstack", line 27, in <module>
sys.exit(deploys.openstack.main())
File "./deploys/bin/../deploys/openstack/__init__.py", line 80, in main
getattr(OSKleverDeveloperInstance(args, logger), args.action)()
File "./deploys/bin/../deploys/openstack/openstack.py", line 393, in update
floating_ip=self._get_instance_floating_ip(self._get_instance(self.name))) as ssh:
File "./deploys/bin/../deploys/openstack/ssh.py", line 41, in init
self.logger.error('Please specify path to SSH RSA private key file with help of command-line option' +
AttributeError: 'SSH' object has no attribute 'logger'

History

#1 Updated by Evgeny Novikov 8 months ago

  • Target version set to 1.0
  • Priority changed from Normal to Immediate
  • Assignee set to Evgeny Novikov
  • Category set to Deployment

This is a stupid regression (use before initialization) introduced recently.

#2 Updated by Evgeny Novikov 8 months ago

  • Status changed from New to Closed

I fixed this issue in cc8a4ab2. The bug fix does not need testing since there isn't any tests for deployment within OpenStack.

Also available in: Atom PDF