Project

General

Profile

Bug #9015

Cannot upload several jobs in one archive

Added by Ilja Zakharov 12 months ago. Updated 12 months ago.

Status:
Rejected
Priority:
Immediate
Assignee:
-
Category:
Bridge
Target version:
Start date:
06/27/2018
Due date:
% Done:

0%

Estimated time:
Detected in build:
svn
Platform:
Published in build:

Description

If I select several root jobs from the jobs tree and download them and trying to upload to another machine I got:

job.json file was not found or contains wrong data
Traceback (most recent call last):
File "/work/zakharov/src/klever/bridge/jobs/views.py", line 351, in get_context_data
UploadJob(self.kwargs['parent_id'], self.request.user, job_dir.name)
File "/work/zakharov/src/klever/bridge/jobs/Download.py", line 518, in init
self.__check_job_data()
File "/work/zakharov/src/klever/bridge/jobs/Download.py", line 543, in __check_job_data
raise ValueError('job.json file was not found or contains wrong data')
ValueError: job.json file was not found or contains wrong data

See the jobs in the


Files

KleverJobs(1).zip (10.8 MB) KleverJobs(1).zip Ilja Zakharov, 06/27/2018 01:40 PM

Related issues

Is duplicate of Klever - Feature #6950: Download and upload archives with several jobs and marks at onceNew03/09/2016

Actions

History

#1

Updated by Evgeny Novikov 12 months ago

  • Priority changed from Urgent to Immediate

This is a regression to be fixed ASAP to be able to release Klever 1.0.

#2

Updated by Vladimir Gratinskiy 12 months ago

Evgeny Novikov wrote:

This is a regression to be fixed ASAP to be able to release Klever 1.0.

Bridge nevere supported such feature. You can upload jobs together after unpacking and selecting jobs you need to upload. The only reason archive with jobs is single because I don't know the way how to download several files at once.

#3

Updated by Evgeny Novikov 12 months ago

  • Is duplicate of Feature #6950: Download and upload archives with several jobs and marks at once added
#4

Updated by Evgeny Novikov 12 months ago

  • Assignee deleted (Vladimir Gratinskiy)
  • Status changed from New to Rejected

Vladimir Gratinskiy wrote:

Evgeny Novikov wrote:

This is a regression to be fixed ASAP to be able to release Klever 1.0.

Bridge nevere supported such feature. You can upload jobs together after unpacking and selecting jobs you need to upload. The only reason archive with jobs is single because I don't know the way how to download several files at once.

Sorry, I had an opposite opinion and asked Ilja to report a bug. Indeed, everything works as expected - #6950.

Also available in: Atom PDF