Project

General

Profile

Bug #9004

Marks created for new traces contains in call stack auxiliary EMG functions

Added by Ilja Zakharov 10 months ago. Updated 10 months ago.

Status:
Closed
Priority:
Immediate
Assignee:
Category:
Environment model
Target version:
Start date:
06/26/2018
Due date:
% Done:

0%

Estimated time:
Detected in build:
svn
Platform:
Published in build:

Description

By design we mark all generated functions as auxiliary and exclude them from call stack at marks creation. This allows to change environment model generation and rule models keeping marks as is. Currently some generated functions again appeared in newly created marks.

History

#1

Updated by Evgeny Novikov 10 months ago

  • Target version changed from 2.0 to 1.0
  • Priority changed from Urgent to Immediate

This is definitely a big degradation since Klever 0.2. We can not release Klever 1.0 until it will be fixed and all related thins will be fixed as well.

#2

Updated by Ilja Zakharov 10 months ago

  • Status changed from New to Resolved

Solved in 9004-trace-actions.

#3

Updated by Evgeny Novikov 10 months ago

  • Status changed from Resolved to Closed

Tests demonstrated just a small difference that was expected. Instead one mark for 2 unsafes now there are 2 marks for these unsafes. I merged the branch to master in 86c265d9. Since there is no more critical issues, the current commit is marked with rc2. If no critical issues will be reported during a couple of days, we will issue 1.0 at last.

Also available in: Atom PDF