Project

General

Profile

Bug #8973

ClassCastException in VcegarPjIcuCfgGraphMlTestCase

Added by Mikhail Lebedev over 1 year ago. Updated 5 months ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Engine (Parser)
Target version:
Start date:
06/19/2018
Due date:
% Done:

100%

Estimated time:
Detected in build:
master
Platform:
Published in build:
1.1.1-beta-190722

Description

This error appears in VcegarPjIcuCfgGraphMlTestCase of the Retrascope-MC-benchmark project.
Log:

java.lang.ClassCastException: ru.ispras.fortress.expression.NodeOperation cannot be cast to ru.ispras.fortress.expression.NodeVariable


at ru.ispras.retrascope.parser.verilog.VerilogCfgProcessBuilder.createAssignment(VerilogCfgProcessBuilder.java:272)
at ru.ispras.retrascope.parser.verilog.VerilogCfgProcessBuilder.parseAssignment(VerilogCfgProcessBuilder.java:343)
at ru.ispras.retrascope.parser.verilog.VerilogCfgProcessBuilder.onAssignStatementBegin(VerilogCfgProcessBuilder.java:488)
at ru.ispras.verilog.parser.walker.VerilogNodeVisitor$3.onBegin(VerilogNodeVisitor.java:265)
at ru.ispras.verilog.parser.walker.VerilogNodeVisitor.onBegin(VerilogNodeVisitor.java:700)
at ru.ispras.verilog.parser.core.TreeWalker.onBegin(TreeWalker.java:100)
at ru.ispras.verilog.parser.core.TreeWalker.start(TreeWalker.java:79)
at ru.ispras.retrascope.parser.verilog.VerilogCfgBuilder.start(VerilogCfgBuilder.java:82)
at ru.ispras.verilog.parser.VerilogDesignBackends.start(VerilogDesignBackends.java:56)
at ru.ispras.verilog.parser.VerilogTranslator.start(VerilogTranslator.java:169)
at ru.ispras.retrascope.parser.verilog.VerilogParser.parse(VerilogParser.java:103)
at ru.ispras.retrascope.parser.basis.HdlParser.start(HdlParser.java:112)
at ru.ispras.retrascope.basis.Engine.start(Engine.java:217)
at ru.ispras.retrascope.basis.ToolChain.start(ToolChain.java:111)
at ru.ispras.retrascope.basis.Engine.start(Engine.java:217)
at ru.ispras.retrascope.Retrascope$ToolRun.start(Retrascope.java:215)
at ru.ispras.retrascope.Retrascope.main(Retrascope.java:456)
at ru.ispras.retrascope.Retrascope.main(Retrascope.java:373)

Corresponding Verilog:

src/main/verilog/vcegar-benchmarks/pj_icu/icctl1.v


Related issues

Related to Retrascope - Task #8994: "BVEXTRACT( ... BVEXTRACT (j i x))" expression transformation rule to the tool rulesetClosed06/25/2018

Actions

History

#1

Updated by Sergey Smolov over 1 year ago

  • Status changed from New to Open

The cause in the "BVEXTRACT)" in the left hand side of the assignment to be created.

#2

Updated by Sergey Smolov over 1 year ago

  • Related to Task #8994: "BVEXTRACT( ... BVEXTRACT (j i x))" expression transformation rule to the tool ruleset added
#3

Updated by Sergey Smolov over 1 year ago

  • % Done changed from 0 to 100
  • Status changed from Open to Resolved
#4

Updated by Mikhail Lebedev over 1 year ago

  • Status changed from Resolved to Verified
#5

Updated by Sergey Smolov over 1 year ago

  • Target version set to 1.0
#6

Updated by Sergey Smolov 10 months ago

  • Category set to Engine (Parser)
#7

Updated by Sergey Smolov 5 months ago

  • Published in build set to 1.1.1-beta-190722
  • Status changed from Verified to Closed

Also available in: Atom PDF