Project

General

Profile

Feature #8889

Support verification job formats properly

Added by Evgeny Novikov about 2 years ago. Updated 5 months ago.

Status:
Closed
Priority:
Urgent
Category:
Bridge
Target version:
Start date:
05/24/2018
Due date:
% Done:

0%

Estimated time:
Published in build:

Description

At the moment verification job formats are fake since they don't work as expected. I suggest to explicitly specify formats for all verification jobs rather than do this globally. Then Core will be able to accept just those verification jobs that have supported formats.


Related issues

Related to Klever - Feature #8434: Get rid of job classesClosed09/18/201712/14/2017

Actions

History

#1

Updated by Evgeny Novikov about 2 years ago

#2

Updated by Evgeny Novikov almost 2 years ago

  • Target version changed from 2.0 to 1.1

This issue is not strictly bound with purposes of 2.0 that targets verification of C software.

#3

Updated by Evgeny Novikov almost 2 years ago

  • Target version changed from 1.1 to 2.0

I suggest quite many changes in Bridge, so, let's wait when Vladimir will return from his vacation.

#4

Updated by Evgeny Novikov over 1 year ago

  • Target version changed from 2.0 to 3.0

This is not so important for Klever 2.0.

#5

Updated by Evgeny Novikov 7 months ago

  • Assignee changed from Evgeny Novikov to Vladimir Gratinskiy
  • Status changed from New to Resolved
  • Category set to Bridge

It turned out that Core have not relied on the verification job format at all (corresponding code was removed one day a long ago). So, Vladimir removed format from Bridge as well in branch klever-3.0.

We decided that this format is not required at the moment since it has sense primarily when different versions of Klever components interact with each other. We have not this ever by design and I am not sure that we will have this one day.

In addition, Vladimir removed formats of some other stuff in Bridge.

#6

Updated by Evgeny Novikov 5 months ago

  • Status changed from Resolved to Closed

In master.

Also available in: Atom PDF