Project

General

Profile

Feature #8651

Consider preset mark file names as mark identifiers

Added by Evgeny Novikov over 1 year ago. Updated over 1 year ago.

Status:
Closed
Priority:
Urgent
Category:
Bridge
Target version:
Start date:
12/27/2017
Due date:
01/09/2018
% Done:

100%

Estimated time:
Published in build:

Description

At the moment Bridge always generate unique identifiers for preset marks that prevents automatic regression testing or even make it impossible. Moreover, one needs to suggest file names for preset marks that often is redundant since this information isn't shown after all anywhere.

I suppose to name each preset mark as "ID.json" where each ID is a sequence of 32 hexadecimal symbols ([0-9a-f]) and it is unique among all preset marks.


Related issues

Related to Klever - Feature #8652: Rename all existing preset marks using file names consisting of 32 hexadecimal symbolsClosed12/27/201701/09/2018

Actions
Blocks Klever - Feature #8650: Allow to download marks in preset formatClosed12/27/201701/09/2018

Actions

History

#1

Updated by Evgeny Novikov over 1 year ago

  • Blocks Feature #8650: Allow to download marks in preset format added
#2

Updated by Evgeny Novikov over 1 year ago

  • Description updated (diff)
#3

Updated by Evgeny Novikov over 1 year ago

  • Related to Feature #8652: Rename all existing preset marks using file names consisting of 32 hexadecimal symbols added
#4

Updated by Vladimir Gratinskiy over 1 year ago

  • % Done changed from 0 to 100
  • Status changed from New to Resolved
  • Due date set to 01/09/2018

Implemented in "marks-imrovements".

#5

Updated by Ilja Zakharov over 1 year ago

  • Status changed from Resolved to Closed

Available since cfc84c84.

Also available in: Atom PDF