Project

General

Profile

Bug #8628

Properly restrict job name lenght

Added by Evgeny Novikov almost 2 years ago. Updated 5 months ago.

Status:
Resolved
Priority:
Urgent
Category:
Bridge
Target version:
Start date:
12/13/2017
Due date:
07/10/2019
% Done:

100%

Estimated time:
Detected in build:
svn
Platform:
Published in build:

Description

At the moment when a user inputs too long job name, Bridge doesn't provide a nice warning.

History

#1

Updated by Evgeny Novikov 5 months ago

  • Detected in build set to svn
  • Target version set to 3.0
  • Priority changed from High to Urgent
  • Tracker changed from Feature to Bug

Moreover, it can corrupt the database. For instance, when I tried to store a job with a long name (after editing existing job files and the job name), Bridge outputted an unknown error. After reducing the job name there was jobs.models.JobHistory.MultipleObjectsReturned .

#2

Updated by Vladimir Gratinskiy 5 months ago

  • Status changed from New to Feedback

Can't reproduce the bug in bridge-3.0.

#3

Updated by Vladimir Gratinskiy 5 months ago

  • % Done changed from 0 to 100
  • Status changed from Feedback to Resolved
  • Due date set to 07/10/2019

There are warnings about big job length, so the bug is not relevant now (bridge-3.0).

Also available in: Atom PDF