Project

General

Profile

Bug #8606

Could not find build command description for drivers/extcon/extcon-core.o of Linux 4.9.65

Added by Evgeny Novikov over 1 year ago. Updated about 1 year ago.

Status:
Closed
Priority:
Urgent
Category:
Program fragments generation
Target version:
Start date:
11/28/2017
Due date:
% Done:

0%

Estimated time:
Detected in build:
svn
Platform:
Published in build:

Description

For the attached job the following error can happen after approximately 3 hours:

[AVODG1] Raise exception:
Traceback (most recent call last):
  File "/home/debian/klever/core/core/components.py", line 413, in run
    self.main()
  File "/home/debian/klever/core/core/components.py", line 320, in callbacks_caller
    ret = attr(*args, **kwargs)
  File "/home/debian/klever/core/core/components.py", line 318, in callbacks_caller
    ret = attr(*args[1:], **kwargs)
  File "/home/debian/klever/core/core/lkvog/__init__.py", line 287, in generate_all_verification_obj_descs
    self.generate_verification_obj_desc()
  File "/home/debian/klever/core/core/components.py", line 320, in callbacks_caller
    ret = attr(*args, **kwargs)
  File "/home/debian/klever/core/core/lkvog/__init__.py", line 319, in generate_verification_obj_desc
    cc_full_desc_files = self.__find_cc_full_desc_files(module.id)
  File "/home/debian/klever/core/core/lkvog/__init__.py", line 444, in __find_cc_full_desc_files
    out_file_desc = self.linux_kernel_build_cmd_out_file_desc[out_file][-1]
  File "<string>", line 2, in __getitem__
  File "/usr/lib/python3.5/multiprocessing/managers.py", line 732, in _callmethod
    raise convert_to_error(kind, result)
KeyError: 'drivers/extcon/extcon-core.o'
[ALKBCDP0] Stop since some other component(s) likely failed
Raise exception:
Traceback (most recent call last):
  File "/home/debian/klever/core/core/components.py", line 413, in run
    self.main()
  File "/home/debian/klever/core/core/components.py", line 320, in callbacks_caller
    ret = attr(*args, **kwargs)
  File "/home/debian/klever/core/core/lkvog/__init__.py", line 88, in generate_linux_kernel_verification_objects
    ('AVODG', self.generate_all_verification_obj_descs))
  File "/home/debian/klever/core/core/components.py", line 320, in callbacks_caller
    ret = attr(*args, **kwargs)
  File "/home/debian/klever/core/core/components.py", line 556, in launch_subcomponents
    launch_workers(self.logger, subcomponent_processes)
  File "/home/debian/klever/core/core/components.py", line 196, in launch_workers
    p.join(1.0 / len(workers))
  File "/home/debian/klever/core/core/components.py", line 320, in callbacks_caller
    ret = attr(*args, **kwargs)
  File "/home/debian/klever/core/core/components.py", line 521, in join
    raise ComponentError('Component "{0}" failed'.format(self.name))
core.components.ComponentError: Component "AVODG1" failed

You can try to get the error faster by considering directory drivers/extcon rather than the whole directory drivers.


Files

job.json (734 Bytes) job.json Evgeny Novikov, 11/28/2017 05:21 PM

Related issues

Related to Klever - Bug #8258: LKVOG crash on module 'drivers/misc/lkdtm.ko'Closed06/23/2017

Actions
Related to Klever - Feature #8664: Refactor relating build commandsRejected01/15/2018

Actions

History

#1

Updated by Evgeny Novikov over 1 year ago

This issue looks like #8258, but I am not sure that their reasons and fixes are the same.

#2

Updated by Evgeny Novikov over 1 year ago

  • Target version changed from 2.0 to 1.0
#3

Updated by Evgeny Novikov over 1 year ago

  • Assignee changed from Alexey Polushkin to Evgeny Novikov

I will try to fix it myself.

#4

Updated by Evgeny Novikov over 1 year ago

  • Assignee changed from Evgeny Novikov to Alexey Polushkin
  • Target version changed from 1.0 to 2.0

The corresponding code is related with multimodule verification objects generation, so that I wouldn't like to touch it. It seems that this issue is just for quite new versions of the Linux kernel, so it isn't so crucial to be included into Klever version:0.3.

The additional note is that it isn't enough to consider just directory drivers/extcon. I could reproduce the issue just for drivers.

#5

Updated by Alexey Polushkin over 1 year ago

  • Status changed from New to Resolved

Resolved in branch 'build_extcon'

#6

Updated by Evgeny Novikov over 1 year ago

  • Related to Feature #8664: Refactor relating build commands added
#7

Updated by Evgeny Novikov about 1 year ago

  • Target version changed from 2.0 to 1.0

Let's include this bug fix into Klever version:0.3.

#8

Updated by Ilja Zakharov about 1 year ago

  • Status changed from Resolved to Verified
#9

Updated by Ilja Zakharov about 1 year ago

  • Status changed from Verified to Closed

Available since edfc1383.

Also available in: Atom PDF