Project

General

Profile

Bug #858

LDV online - set 'Build failed' to task when build description contains SOAP warning messages

Added by Alexandr Strakh over 8 years ago. Updated almost 8 years ago.

Status:
New
Priority:
Low
Assignee:
-
Category:
Infrastructure
Start date:
02/18/2011
Due date:
03/14/2011
% Done:

0%

Estimated time:
Detected in build:
4fa890991696854d47f61e31e51bf3184368a880
Platform:
Published in build:
79a67e2

Description

Warning messages from some impelementations of SOAP::Lite returns to online through build description. In this case online set 'Build failed' to current task.
For now I removed '-w' perl option from ldv scripts (only in node instance). It must be fixed.

History

#1

Updated by Alexey Khoroshilov over 8 years ago

  • Priority changed from Normal to High
#2

Updated by Pavel Shved over 8 years ago

  • Due date set to 03/14/2011
  • Status changed from New to Open
  • Assignee changed from Alexandr Strakh to Pavel Shved

The problem is, of course, greater than just SOAP warnings. Build should not be "failed" just based on warnings printed to STDERR.

We'll address the problem this sprint.

#3

Updated by Pavel Shved about 8 years ago

  • Assignee changed from Pavel Shved to Evgeny Novikov

First, we discovered that output to STDERR does not affect whether build is considered failed.

Second, the warnings are issued by a mismatch of SOAP::Lite module code and modern Perl version deployed on the node. The solution to this bug would be to suppress warnings during including modules. With help of Konstantin Vlasov, we discovered that

use SOAP::Lite;

should be substituted with

BEGIN { $SIG{'__WARN__'} = sub{}; require SOAP::Lite; SOAP::Lite->import(); $SIG{__WARN__}='DEFAULT'; }

in as_gcc and ldv-core scripts.

#4

Updated by Evgeny Novikov about 8 years ago

  • Category changed from LDV-Online (the web service) to Infrastructure
  • Status changed from Open to Resolved
  • Published in build set to 79a67e2

Small test set shows no regression. So merged to master. Should be tested on real online and then be closed.

#5

Updated by Evgeny Novikov about 8 years ago

  • Status changed from Resolved to Closed

LDV-Online shows the issue to have gone http://linuxtesting.org/ldv/online?action=get_status&task_id=3&number=3. But if it'll come back in the some way I think that more detailed view into documentation (like http://perldoc.perl.org/perllexwarn.html and related pages) should be done

#6

Updated by Vadim Mutilin about 8 years ago

  • Status changed from Closed to Open
#7

Updated by Evgeny Novikov about 8 years ago

  • Assignee deleted (Evgeny Novikov)

I noticed that such the warnings again find the way to penetrate into build description. So file bce_tempdir/report_after_bce.xml tail is so:

Service description 'http://localhost:8080/csd44242011181654?wsdl' can't be loaded: 500 Can't connect to localhost:8080 (connect: Connection refused)
make[2]: *** [drivers/media/dvb/ttusb-budget/dvb-ttusb-budget.o] Error 111
make[1]: *** [_module_drivers/media/dvb/ttusb-budget] Error 2
Compile error.  Maybe the driver the patch introduces is not turned on on make allmodconfig?
    </desc>
  </build>
</reports>

In fact there is still direct using of SOAP::Lite module in files:
build-cmd-extractor/
  is_empty.pl
  reroute-stream
  bce_gcc

I suggest that they are responsible for this issue.

#8

Updated by Pavel Shved about 8 years ago

Is it in the LDV-online interface (which is down at the moment due to security audit as far as I know)?

#9

Updated by Evgeny Novikov about 8 years ago

This was obtained locally. You can see issue #1064 to find out how to reproduce it.

#10

Updated by Pavel Shved almost 8 years ago

  • Status changed from Open to New
  • Priority changed from High to Low

I couldn't reproduce it anyway.
So we decided to postpone this. If someone manages to reproduce — rise priority ASAP!

Also available in: Atom PDF