Project

General

Profile

Bug #8512

Cannot update OpenStack instance after creation

Added by Ilja Zakharov over 1 year ago. Updated over 1 year ago.

Status:
Closed
Priority:
Immediate
Category:
Deployment
Target version:
Start date:
10/19/2017
Due date:
% Done:

0%

Estimated time:
Detected in build:
svn
Platform:
Published in build:

Description

Cannot update OpenStack instance after successful creation. Got the following exception:

File "/work/zakharov/src/klever/deploys/bin/deploy-openstack", line 27, in <module>
sys.exit(kopenstack.main())
File "/work/zakharov/src/klever/deploys/kopenstack/__init__.py", line 66, in main
execute_os_entity_action(args, logger)
File "/work/zakharov/src/klever/deploys/kopenstack/kopenstack.py", line 722, in execute_os_entity_action
getattr(OSKleverDeveloperInstance(args, logger), args.action)()
File "/work/zakharov/src/klever/deploys/kopenstack/kopenstack.py", line 468, in update
self._do_update(ssh)
File "/work/zakharov/src/klever/deploys/kopenstack/kopenstack.py", line 383, in do_update
instance_klever_conf = json.load(fp)
File "/usr/lib/python3.5/json/
_init__.py", line 268, in load
parse_constant=parse_constant, object_pairs_hook=object_pairs_hook, **kw)
File "/usr/lib/python3.5/json/__init__.py", line 312, in loads
s.__class__.__name__))
TypeError: the JSON object must be str, not 'bytes'

History

#1

Updated by Evgeny Novikov over 1 year ago

  • Priority changed from Urgent to Immediate

This is a very unpleasant issue since it breaks the standard deployment workflow. I will consider its backporting to the stable branch of Klever 0.2.

#2

Updated by Evgeny Novikov over 1 year ago

  • Status changed from New to Open

The issue is caused by recent changes in Python standard library module json. Starting from Python 3.6 it accepts bytes: https://docs.python.org/3/library/json.html?highlight=json#json.loads.

#3

Updated by Evgeny Novikov over 1 year ago

  • Status changed from Open to Closed

I fixed this in 3953534a to master. In addition, I specified requirements for deploying Klever within OpenStack clouds.

Also available in: Atom PDF