Project

General

Profile

Feature #8501

Jobs can be pending forever when keeping working directories

Added by Evgeny Novikov over 1 year ago. Updated over 1 year ago.

Status:
Rejected
Priority:
Urgent
Assignee:
-
Category:
Scheduling
Target version:
Start date:
10/16/2017
Due date:
% Done:

0%

Estimated time:
Published in build:

Description

I have started several jobs. It looks like the first one occupied so much memory that other jobs weren't started. Besides, each job required 100 GB of disk space while there was about 110 GB in total. When the first job was completed other jobs still weren't started. I guess that the problem was related with that there wasn't enough disk space left (Native Scheduler kept working directories), but scheduler didn't fail that jobs.

History

#1 Updated by Evgeny Novikov over 1 year ago

  • Description updated (diff)

#2 Updated by Ilja Zakharov over 1 year ago

  • Status changed from New to Feedback

Please, clarify do you run jobs with keeping directories flag? If it is so. then it is a feature and it is not a bug, because this is a debugging option only for development as I already told you before. But if the issue can be reproduced with either only a main memory restriction or without keeping directories, then it should be fixed. But I doubt that something works wrong here.

#3 Updated by Evgeny Novikov over 1 year ago

  • Tracker changed from Bug to Feature
  • Subject changed from Jobs can be pending forever to Jobs can be pending forever when keeping working directories
  • Status changed from Feedback to Rejected
  • Assignee deleted (Ilja Zakharov)

Okay, now I catch what this feature really means and suggest to remain everything as is.

Also available in: Atom PDF