Project

General

Profile

Feature #8444

Restore progress calculation

Added by Ilja Zakharov about 3 years ago. Updated about 3 years ago.

Status:
Rejected
Priority:
Urgent
Assignee:
-
Category:
Bridge
Target version:
Start date:
09/19/2017
Due date:
% Done:

0%

Estimated time:
Published in build:

Description

Regarding the recent refactoring, I have broken calculation of the progress. Moreover, core currently generates tasks a bit differently and it is not easy to restore it. I propose to introduce additional reports with the progress that will not be connected with any particular Core components. For instance, each Core sub-job in some component just can send Bridge information about the current progress: the number of tasks that will be generated, the number of tasks that are failed and the number of tasks that will be solved.


Related issues

Related to Klever - Feature #7800: Refactoring of VTGClosed12/13/2016

Actions
Is duplicate of Klever - Feature #8149: Think on proper progress evaluation when several jobs are solved at once or/and much computational resources are availableClosed09/20/201710/26/2017

Actions

History

#1

Updated by Ilja Zakharov about 3 years ago

Comments and ideas are welcome.

I propose to implement the support of such requests and then I will fix the Core component.

#2

Updated by Evgeny Novikov about 3 years ago

I suggest to reject this issue since it likely requires too much time but won't fix progress calculation completely as it is required by #8149.

#3

Updated by Evgeny Novikov about 3 years ago

  • Status changed from New to Rejected
  • Assignee deleted (Vladimir Gratinskiy)

Also available in: Atom PDF