Project

General

Profile

Bug #8443

Error at creation of mark without tags

Added by Ilja Zakharov about 3 years ago. Updated about 3 years ago.

Status:
Closed
Priority:
Immediate
Category:
Bridge
Target version:
Start date:
09/19/2017
Due date:
09/19/2017
% Done:

100%

Estimated time:
Detected in build:
svn
Platform:
Published in build:

Description

I get an exception with the following message trying to create a mark (without tags):

Deleting ReportRoot files took 0.004965543746948242 seconds.
'tags'
Traceback (most recent call last):
File "/work/zakharov/src/klever/bridge/marks/views.py", line 518, in association_changes
data = AssociationChangesTable(request.user, association_id, **view_add_args)
File "/work/zakharov/src/klever/bridge/marks/tables.py", line 876, in init
self.values = self.__get_values()
File "/work/zakharov/src/klever/bridge/marks/tables.py", line 980, in __get_values
.render({'tags': self._data['values'][report_id]['tags'], 'type': mark_type})
KeyError: 'tags'

History

#1

Updated by Evgeny Novikov about 3 years ago

  • Subject changed from Error at creation of an empty mark to Error at creation of mark without tags
  • Priority changed from Urgent to Immediate

This looks like a serious regression bug introduced in master after Klever 0.1 was released.

#2

Updated by Vladimir Gratinskiy about 3 years ago

  • Due date set to 09/19/2017
  • Status changed from New to Resolved
  • % Done changed from 0 to 100

The bug happened on mark association changes page visualization. There were no problems during mark creation.
I fixed the bug in branch fix_8443.

#3

Updated by Evgeny Novikov about 3 years ago

  • Status changed from Resolved to Closed

Looks to work, so, I merged the branch to master in bf3f5a80.

Also available in: Atom PDF