Project

General

Profile

Feature #8368

Downloaded component files contain only log files

Added by Evgeny Novikov about 3 years ago. Updated almost 3 years ago.

Status:
Closed
Priority:
High
Category:
Bridge
Target version:
Start date:
08/19/2017
Due date:
% Done:

0%

Estimated time:
Published in build:

Description

Likely some recent changes resulted in for all components except CPAchecker downloaded component files contain only log files. As far as I remember there wasn't button "Download files" before in such cases. So, this looks like a regression.

History

#1

Updated by Vladimir Gratinskiy about 3 years ago

Evgeny Novikov wrote:

Likely some recent changes resulted in for all components except CPAchecker downloaded component files contain only log files. As far as I remember there wasn't button "Download files" before in such cases.

It never was so.

#2

Updated by Evgeny Novikov about 3 years ago

  • Tracker changed from Bug to Feature
  • Priority changed from Immediate to High

Vladimir Gratinskiy wrote:

Evgeny Novikov wrote:

Likely some recent changes resulted in for all components except CPAchecker downloaded component files contain only log files. As far as I remember there wasn't button "Download files" before in such cases.

It never was so.

So, I was just surprised that we have this now after an ability to send several file archives was introduced (this was done to separate source files for coverage reports). Please, consider this as a feature request - do not allow "Download files" for components that do not send anything except log files for showing which there is a dedicated button.

Also we need to decide how to send files except files for coverage reports that are already sent gracefully. From the beginning all files (log files, problem descriptions, error traces and source files referred by them, verifier input files, etc.) were sent using the same report attribute files. I suppose to restrict this usage by sending with this attribute just independent files each of which is referenced directly by name in a corresponding report (e.g. log files and problem descriptions). For the rest, say, error traces and source files referred by them, verifier input files, always use new dedicated report file attributes.

What do you think about that?

#3

Updated by Vladimir Gratinskiy about 3 years ago

Evgeny Novikov wrote:

Vladimir Gratinskiy wrote:

Evgeny Novikov wrote:

Likely some recent changes resulted in for all components except CPAchecker downloaded component files contain only log files. As far as I remember there wasn't button "Download files" before in such cases.

It never was so.

So, I was just surprised that we have this now after an ability to send several file archives was introduced (this was done to separate source files for coverage reports). Please, consider this as a feature request - do not allow "Download files" for components that do not send anything except log files for showing which there is a dedicated button.

So always when you load report page its archive will be opened and checked if there are any files except log there.

Also we need to decide how to send files except files for coverage reports that are already sent gracefully. From the beginning all files (log files, problem descriptions, error traces and source files referred by them, verifier input files, etc.) were sent using the same report attribute files. I suppose to restrict this usage by sending with this attribute just independent files each of which is referenced directly by name in a corresponding report (e.g. log files and problem descriptions). For the rest, say, error traces and source files referred by them, verifier input files, always use new dedicated report file attributes.

What do you think about that?

Just renaming? I don't think it will be complicated to do.

#4

Updated by Evgeny Novikov about 3 years ago

Vladimir Gratinskiy wrote:

Evgeny Novikov wrote:

Vladimir Gratinskiy wrote:

Evgeny Novikov wrote:

Likely some recent changes resulted in for all components except CPAchecker downloaded component files contain only log files. As far as I remember there wasn't button "Download files" before in such cases.

It never was so.

So, I was just surprised that we have this now after an ability to send several file archives was introduced (this was done to separate source files for coverage reports). Please, consider this as a feature request - do not allow "Download files" for components that do not send anything except log files for showing which there is a dedicated button.

So always when you load report page its archive will be opened and checked if there are any files except log there.

I don't understand why is it necessary in such the way. All API sanity checks should be performed when reports are uploaded to warn or even to corrupt job decisions as early as possible. You can check that all files from "report files archive.zip" are explicitly referenced by a corresponding report.

Also we need to decide how to send files except files for coverage reports that are already sent gracefully. From the beginning all files (log files, problem descriptions, error traces and source files referred by them, verifier input files, etc.) were sent using the same report attribute files. I suppose to restrict this usage by sending with this attribute just independent files each of which is referenced directly by name in a corresponding report (e.g. log files and problem descriptions). For the rest, say, error traces and source files referred by them, verifier input files, always use new dedicated report file attributes.

What do you think about that?

Just renaming? I don't think it will be complicated to do.

I think that some extra changes will be necessary. For instance, now you are likely manually separate log files and verifier input files combined together within one archive. After this change you can skip reading of verifier input files archive at all.

#5

Updated by Evgeny Novikov almost 3 years ago

  • Status changed from New to Closed
  • Target version set to 0.2

Everything related was fixed in master and everything looks like it should look now.

Also available in: Atom PDF