Project

General

Profile

Feature #8342

Show the number of confirmed bugs, false alarms, etc. at jobs tree page

Added by Evgeny Novikov about 3 years ago. Updated almost 3 years ago.

Status:
Closed
Priority:
Urgent
Category:
Bridge
Target version:
Start date:
08/13/2017
Due date:
% Done:

10%

Estimated time:
Published in build:

Description

As Pavel noticed in https://forge.ispras.ru/issues/8336#note-8, there isn't such the information at the jobs tree page, so it looks differently from the job page. I suppose to show this information there as at the job page, i.e. in form "the number of confirmed X (the total number of X)" within corresponding columns without introducing any new columns.


Related issues

Related to Klever - Feature #8336: Option to hide unconfirmed unsafesClosed08/11/201708/11/2017

Actions

History

#1

Updated by Evgeny Novikov about 3 years ago

Also I suppose to show the total number of confirmed unsafes and safes at the job page. Now it looks like:

Unsafes (17)
Target bugs: 8 (11)
False positives: 1 (1)
Incompatible marks: 1 (3)
Without marks: 2

I suggest to do it like:
Unsafes: 10 (17)
Target bugs: 8 (11)
False positives: 1 (1)
Incompatible marks: 1 (3)
Without marks: 2

#2

Updated by Vladimir Gratinskiy about 3 years ago

  • % Done changed from 0 to 10

Total nubmer of confirmed unsafes/safes is implemented in branch "feature_8342".

But for showing confirmed verdicts on job tree page I have to get rid of verdicts numbers cache (I don't want to create new cache with total numbers of confirmed safes/unsafes as it is too hard to update it, I already tried to implement it), so the jobs tree page will load longer. And Verdicts cache table is not used anymore then and I can delete it. So marks connections functions will be faster because they don't need to update the cache. As you see it is a lot of changes for just to show confirmed verdicts. Do you realy need it on jobs tree page?

#3

Updated by Evgeny Novikov about 3 years ago

Vladimir Gratinskiy wrote:

Total nubmer of confirmed unsafes/safes is implemented in branch "feature_8342".

This is a minor improvement.

But for showing confirmed verdicts on job tree page I have to get rid of verdicts numbers cache (I don't want to create new cache with total numbers of confirmed safes/unsafes as it is too hard to update it, I already tried to implement it), so the jobs tree page will load longer. And Verdicts cache table is not used anymore then and I can delete it. So marks connections functions will be faster because they don't need to update the cache. As you see it is a lot of changes for just to show confirmed verdicts. Do you realy need it on jobs tree page?

Of course I prefer a new cache since for us it's more important to show statistics faster rather than to, say, create marks, because of the former is used much more times than the latter. For the latter, I guess, an overhead will be also quite low. So, the only question is that it is a complicated task which can consume much time. I think that now we can do this.

#4

Updated by Vladimir Gratinskiy about 3 years ago

Version without cache is implemented in branch "feature_8342". Job's tree loading is about 3 times longer than it was before.

#5

Updated by Evgeny Novikov about 3 years ago

  • Status changed from New to Resolved

The suggested solution should be tested with large data sets. Perhaps it will turn out to be inappropriate.

#6

Updated by Evgeny Novikov about 3 years ago

  • Target version set to 0.2
#7

Updated by Evgeny Novikov almost 3 years ago

  • Status changed from Resolved to Closed

After testing on a large production database I merged the branch to master in eec15ccc. Unfortunately, I also mentioned 3 times slower page load. But I hope that one day we will perform required optimizations.

Also available in: Atom PDF