Project

General

Profile

Feature #8336

Option to hide unconfirmed unsafes

Added by Pavel Andrianov over 2 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
High
Category:
Bridge
Target version:
-
Start date:
08/11/2017
Due date:
08/11/2017
% Done:

100%

Estimated time:
Published in build:

Description

Mark confirmation is an interesting feature, but not for unprepared user. Seems, general user does not spend time every launch for confirmation all marked unsafes. Thus, it looks like there should be an "easy mode" for statistics (Job page) without confirmed and unconfirmed results - just one number for every line.


Related issues

Related to Klever - Feature #8342: Show the number of confirmed bugs, false alarms, etc. at jobs tree pageClosed08/13/2017

Actions

History

#1

Updated by Evgeny Novikov over 2 years ago

  • Category set to Bridge

May be a corresponding help message like for consumed computational resources will be better? I don't believe that having more options will be better in such cases.

#2

Updated by Evgeny Novikov over 2 years ago

  • Status changed from New to Feedback
  • Priority changed from Normal to High

Anyway looks trivial for implementation and quite convenient.

#3

Updated by Vladimir Gratinskiy over 2 years ago

  • Due date set to 08/11/2017
  • Status changed from Feedback to Resolved
  • % Done changed from 0 to 100

Implemented in branch "feature_8336".

#4

Updated by Evgeny Novikov over 2 years ago

  • Status changed from Resolved to Feedback

You implemented this as an option, but I asked Pavel to provide a feedback. I guess that having a help message will be better.

#5

Updated by Vladimir Gratinskiy over 2 years ago

Evgeny Novikov wrote:

You implemented this as an option, but I asked Pavel to provide a feedback. I guess that having a help message will be better.

Can't do help message popup on automatically updated part of job page (everything unsader the "view" bar).

#6

Updated by Evgeny Novikov over 2 years ago

Vladimir Gratinskiy wrote:

Evgeny Novikov wrote:

You implemented this as an option, but I asked Pavel to provide a feedback. I guess that having a help message will be better.

Can't do help message popup on automatically updated part of job page (everything unsader the "view" bar).

So, I am wondering how did you implement "?" for consumed computational resources.

#7

Updated by Vladimir Gratinskiy over 2 years ago

Evgeny Novikov wrote:

Vladimir Gratinskiy wrote:

Evgeny Novikov wrote:

You implemented this as an option, but I asked Pavel to provide a feedback. I guess that having a help message will be better.

Can't do help message popup on automatically updated part of job page (everything unsader the "view" bar).

So, I am wondering how did you implement "?" for consumed computational resources.

Before updating I hide this popup in javascript, then update data, then initialize popup, then if it was shown before update I show it again. For verdicts I have to set unique id for each popup to know which one show be shown after update. Set of verdicts is not fixed, it is too complicated to handle with it.

#8

Updated by Pavel Andrianov over 2 years ago

The idea was, that unprepared user does not confirm all unsafes after relaunch the job. Not to confuse him with zero numbers (confirmed bugs), we should show that most of marks are applied. Anyway, in job tree all bugs (not confirmed) are shown. And at job page the same number is hidden into braces. A user should see equal number of bugs both on job tree page and at job page, so, I suggested to hide the detailed information (about confirmed unsafes).

A help message may be useful, but it is likely a secondary feature.

#9

Updated by Evgeny Novikov over 2 years ago

Vladimir Gratinskiy wrote:

Evgeny Novikov wrote:

Vladimir Gratinskiy wrote:

Evgeny Novikov wrote:

You implemented this as an option, but I asked Pavel to provide a feedback. I guess that having a help message will be better.

Can't do help message popup on automatically updated part of job page (everything unsader the "view" bar).

So, I am wondering how did you implement "?" for consumed computational resources.

Before updating I hide this popup in javascript, then update data, then initialize popup, then if it was shown before update I show it again. For verdicts I have to set unique id for each popup to know which one show be shown after update. Set of verdicts is not fixed, it is too complicated to handle with it.

Perhaps it would be better to send such the popups each time when updating pages. Another solution is to store help messages in immutable places, e.g. static help pages and just reference them.

#10

Updated by Evgeny Novikov over 2 years ago

Pavel Andrianov wrote:

The idea was, that unprepared user does not confirm all unsafes after relaunch the job. Not to confuse him with zero numbers (confirmed bugs), we should show that most of marks are applied. Anyway, in job tree all bugs (not confirmed) are shown. And at job page the same number is hidden into braces. A user should see equal number of bugs both on job tree page and at job page, so, I suggested to hide the detailed information (about confirmed unsafes).

This isn't the "unprepared" user - this is the lazy user. And I insist to "confuse" such the users with different numbers, so, nobody will think about them as heroes. Who prevents lazy users to rely upon numbers in braces?.. Help messages will guide them to do this or to do all the best.

I agree that we missed the number of confirmed bugs, false alarms, etc. at the jobs tree page.

#11

Updated by Vadim Mutilin over 2 years ago

This isn't the "unprepared" user - this is the lazy user.

Users always want as much automation as possible. At the same time users want as simple representation as possible, because overflowing information misleads the user.
The confirmation mechanism is not demanded by some users. In such case I would prefer an option to hide it.

#12

Updated by Evgeny Novikov over 2 years ago

  • Status changed from Feedback to Open
  • Assignee set to Vladimir Gratinskiy

Okay, let's do this one day. Since help messages are tricky and weren't implied originally, I will open a separate issue for them.

#13

Updated by Evgeny Novikov over 2 years ago

Vladimir Gratinskiy wrote:

Implemented in branch "feature_8336".

The number of confirmed unsafes is also shown at the unsafes list page and, maybe, somewhere else. Did you enhance corresponding views as well?

#14

Updated by Vladimir Gratinskiy over 2 years ago

Evgeny Novikov wrote:

Vladimir Gratinskiy wrote:

Implemented in branch "feature_8336".

The number of confirmed unsafes is also shown at the unsafes list page and, maybe, somewhere else. Did you enhance corresponding views as well?

Fixed.

#15

Updated by Evgeny Novikov over 2 years ago

  • Status changed from Open to Closed

Looks good although wrong, so, I merged the branch to master in 112d3b4c. Everybody who likes such representations needs to tune their views.

Also available in: Atom PDF