Project

General

Profile

Bug #7984

Visualization shoudn't hide 'note' from analysis

Added by Anton Vasilyev about 3 years ago. Updated about 3 years ago.

Status:
Closed
Priority:
Immediate
Category:
Bridge
Target version:
-
Start date:
02/17/2017
Due date:
02/17/2017
% Done:

100%

Estimated time:
Detected in build:
svn
Platform:
Published in build:

Description

Edge with note at 464 static struct i2c_driver it913x_driver = ...
http://ldvstore:8998/reports/unsafe/167682/

These notes were shown at klever 681261a5434a1e671f9006e0b7a7599bac248760


Files

witness.0.graphml (64.2 KB) witness.0.graphml Anton Vasilyev, 02/17/2017 01:15 PM

History

#1

Updated by Evgeny Novikov about 3 years ago

  • Assignee changed from Evgeny Novikov to Vladimir Gratinskiy
  • Priority changed from High to Immediate

Looks like this is caused by recent changes.

#2

Updated by Vladimir Gratinskiy about 3 years ago

I don't remember when notes were shown in "Global variable declarations" block.

#3

Updated by Vladimir Gratinskiy about 3 years ago

  • Due date set to 02/17/2017
  • Status changed from New to Resolved
  • % Done changed from 0 to 100

Fixed in feature_7164.

#4

Updated by Evgeny Novikov about 3 years ago

This really didn't happen before until we started to verify rule specification generic:memory. Also please check whether global declarations section is shown when there are notes inside it.

#5

Updated by Evgeny Novikov about 3 years ago

  • Status changed from Resolved to Open

Vladimir, please, check whether global declarations section is shown when there are notes inside it. If not then fix this.

#6

Updated by Vladimir Gratinskiy about 3 years ago

Evgeny Novikov wrote:

Vladimir, please, check whether global declarations section is shown when there are notes inside it. If not then fix this.

Global declarations with notes/warnings are shown by default.

#7

Updated by Evgeny Novikov about 3 years ago

  • Status changed from Open to Closed

It works, so I cherry picked 3f69ec5 and 48484c2 to master.

Also available in: Atom PDF