Project

General

Profile

Bug #7895

Parsing failed: Duplicate label in CPAchecker input

Added by Vadim Mutilin almost 3 years ago. Updated almost 3 years ago.

Status:
Rejected
Priority:
Urgent
Assignee:
-
Category:
-
Start date:
01/24/2017
Due date:
% Done:

0%

Estimated time:
Detected in build:
svn
Platform:
Published in build:

Description

The problems listed here http://ldvstore:8998/reports/component/3034/unknowns/4/problem/27/
are due to duplicated label containing in the input files to CPAchecker.

GCC reports an error.

/home/debian/klever-work/native-scheduler-work-dir/scheduler/jobs/1492815773b132c0dfa2172638905312/klever-core-work-dir/0f4725e/082bf89/lkbce/drivers/rtc/rtc-dev.c: In function ‘rtc_dev_read’:
/home/debian/klever-work/native-scheduler-work-dir/scheduler/jobs/1492815773b132c0dfa2172638905312/klever-core-work-dir/0f4725e/082bf89/lkbce/drivers/rtc/rtc-dev.c:198:9: error: duplicate label ‘ldv_20463’
/home/debian/klever-work/native-scheduler-work-dir/scheduler/jobs/1492815773b132c0dfa2172638905312/klever-core-work-dir/0f4725e/082bf89/lkbce/drivers/rtc/rtc-dev.c:198:7: note: previous definition of ‘ldv_20463’ was here
/home/debian/klever-work/native-scheduler-work-dir/scheduler/jobs/1492815773b132c0dfa2172638905312/klever-core-work-dir/0f4725e/082bf89/lkbce/drivers/rtc/rtc-dev.c:201:9: error: duplicate label ‘ldv_20472’
/home/debian/klever-work/native-scheduler-work-dir/scheduler/jobs/1492815773b132c0dfa2172638905312/klever-core-work-dir/0f4725e/082bf89/lkbce/drivers/rtc/rtc-dev.c:201:7: note: previous definition of ‘ldv_20472’ was here


Related issues

Is duplicate of C Instrumentation Framework - Bug #5407: Duplicated labels are generatedClosed11/05/2014

Actions

History

#1

Updated by Evgeny Novikov almost 3 years ago

  • Project changed from Klever to C Instrumentation Framework
  • Status changed from New to Rejected

Just duplicates #5407.

Also available in: Atom PDF