Project

General

Profile

Bug #7823

Ошибки при redo удаления фрагмента

Added by Viktoria Kopach almost 4 years ago. Updated about 2 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Start date:
12/26/2016
Due date:
% Done:

100%

Estimated time:
Detected in build:
0.21.278
Platform:
Windows x64
Published in build:
0.21.279

Description

Удаляем подряд несколько фрагментов в Requality Explorer.
Для всех удалений делаем Undo.
Дальше делаем Redo.

В какой-то момент, возможно при попытке посмотреть Properties view на вкладке Description, возникают ошибки в Error log вида:

eclipse.buildId=4.4.2.M20150204-1700
java.version=1.8.0_101
java.vendor=Oracle Corporation
BootLoader constants: OS=win32, ARCH=x86, WS=win32, NL=ru_RU
Framework arguments:  -product org.eclipse.epp.package.standard.product -eclipse.keyring C:\Users\nicke\rcpttWorkspace\.metadata\.plugins\org.eclipse.pde.core\Requality_Luna/secure_storage
Command-line arguments:  -product org.eclipse.epp.package.standard.product -data C:\Users\nicke\rcpttWorkspace/../aut-Requality_Luna -dev file:C:/Users/nicke/rcpttWorkspace/.metadata/.plugins/org.eclipse.pde.core/Requality_Luna/dev.properties -os win32 -ws win32 -arch x86 -consoleLog -eclipse.keyring C:\Users\nicke\rcpttWorkspace\.metadata\.plugins\org.eclipse.pde.core\Requality_Luna/secure_storage

org.eclipse.ui
Error
Mon Dec 26 17:38:55 MSK 2016
Unhandled event loop exception

org.eclipse.swt.SWTException: Failed to execute runnable (java.lang.RuntimeException: node not found: b44bf274-8e0b-42bf-900a-9a7a777b28f5)
    at org.eclipse.swt.SWT.error(SWT.java:4441)
    at org.eclipse.swt.SWT.error(SWT.java:4356)
    at org.eclipse.swt.widgets.Synchronizer.runAsyncMessages(Synchronizer.java:139)
    at org.eclipse.swt.widgets.Display.runAsyncMessages(Display.java:4147)
    at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:3764)
    at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine$9.run(PartRenderingEngine.java:1151)
    at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:332)
    at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine.run(PartRenderingEngine.java:1032)
    at org.eclipse.e4.ui.internal.workbench.E4Workbench.createAndRunUI(E4Workbench.java:148)
    at org.eclipse.ui.internal.Workbench$5.run(Workbench.java:636)
    at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:332)
    at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Workbench.java:579)
    at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.java:150)
    at org.eclipse.ui.internal.ide.application.IDEApplication.start(IDEApplication.java:135)
    at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:196)
    at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:134)
    at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:104)
    at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:380)
    at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:235)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
    at java.lang.reflect.Method.invoke(Unknown Source)
    at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:648)
    at org.eclipse.equinox.launcher.Main.basicRun(Main.java:603)
    at org.eclipse.equinox.launcher.Main.run(Main.java:1465)
    at org.eclipse.equinox.launcher.Main.main(Main.java:1438)
Caused by: java.lang.RuntimeException: node not found: b44bf274-8e0b-42bf-900a-9a7a777b28f5
    at com.unitesk.requality.core.TreeDB.getNode(TreeDB.java:772)
    at com.unitesk.requality.core.TreeDB.getNode(TreeDB.java:750)
    at com.unitesk.requality.core.TreeNode.getChild(TreeNode.java:792)
    at com.unitesk.requality.core.TreeNode.getChild(TreeNode.java:780)
    at com.unitesk.requality.eclipse.views.properties.AltDescriptionPropertySection$2.getChildren(AltDescriptionPropertySection.java:306)
    at org.eclipse.jface.viewers.AbstractTreeViewer.getRawChildren(AbstractTreeViewer.java:1372)
    at org.eclipse.jface.viewers.TreeViewer.getRawChildren(TreeViewer.java:353)
    at org.eclipse.jface.viewers.StructuredViewer.getFilteredChildren(StructuredViewer.java:905)
    at org.eclipse.jface.viewers.AbstractTreeViewer.getSortedChildren(AbstractTreeViewer.java:617)
    at org.eclipse.jface.viewers.AbstractTreeViewer$1.run(AbstractTreeViewer.java:815)
    at org.eclipse.swt.custom.BusyIndicator.showWhile(BusyIndicator.java:70)
    at org.eclipse.jface.viewers.AbstractTreeViewer.createChildren(AbstractTreeViewer.java:791)
    at org.eclipse.jface.viewers.TreeViewer.createChildren(TreeViewer.java:611)
    at org.eclipse.jface.viewers.AbstractTreeViewer.internalExpandToLevel(AbstractTreeViewer.java:1765)
    at org.eclipse.jface.viewers.AbstractTreeViewer.internalExpandToLevel(AbstractTreeViewer.java:1775)
    at org.eclipse.jface.viewers.AbstractTreeViewer.expandToLevel(AbstractTreeViewer.java:1071)
    at org.eclipse.jface.viewers.AbstractTreeViewer.expandToLevel(AbstractTreeViewer.java:1052)
    at org.eclipse.jface.viewers.AbstractTreeViewer.expandAll(AbstractTreeViewer.java:1041)
    at com.unitesk.requality.eclipse.views.properties.AltDescriptionPropertySection.setTreeNode(AltDescriptionPropertySection.java:405)
    at com.unitesk.requality.eclipse.views.properties.TreeNodePropertiesTab$2.run(TreeNodePropertiesTab.java:257)
    at org.eclipse.swt.widgets.RunnableLock.run_aroundBody0(RunnableLock.java:35)
    at org.eclipse.swt.widgets.RunnableLock$AjcClosure1.run(RunnableLock.java:1)
    at org.eclipse.rcptt.tesla.swt.aspects.DisplayAspect.ajc$around$org_eclipse_rcptt_tesla_swt_aspects_DisplayAspect$10$90b1ba39proceed(DisplayAspect.aj:1)
    at org.eclipse.rcptt.tesla.swt.aspects.DisplayAspect.ajc$around$org_eclipse_rcptt_tesla_swt_aspects_DisplayAspect$10$90b1ba39(DisplayAspect.aj:367)
    at org.eclipse.swt.widgets.RunnableLock.run_aroundBody2(RunnableLock.java:35)
    at org.eclipse.swt.widgets.RunnableLock$AjcClosure3.run(RunnableLock.java:1)
    at org.eclipse.rcptt.sherlock.aspects.swt.DisplayAspect.ajc$around$org_eclipse_rcptt_sherlock_aspects_swt_DisplayAspect$2$90b1ba39proceed(DisplayAspect.aj:1)
    at org.eclipse.rcptt.sherlock.aspects.swt.DisplayAspect.ajc$around$org_eclipse_rcptt_sherlock_aspects_swt_DisplayAspect$2$90b1ba39(DisplayAspect.aj:63)
    at org.eclipse.swt.widgets.RunnableLock.run(RunnableLock.java:35)
    at org.eclipse.swt.widgets.Synchronizer.runAsyncMessages(Synchronizer.java:136)
    ... 24 more

History

#1

Updated by Viktoria Kopach almost 4 years ago

  • Description updated (diff)
#2

Updated by Viktoria Kopach almost 4 years ago

  • Description updated (diff)
#3

Updated by Denis Kildishev almost 4 years ago

  • Status changed from New to Resolved
  • % Done changed from 0 to 100
  • Published in build set to 0_21_279
#4

Updated by Denis Kildishev almost 4 years ago

  • Published in build changed from 0_21_279 to 0.21.279
#5

Updated by Viktoria Kopach almost 4 years ago

  • Status changed from Resolved to Verified
#6

Updated by Alexey Khoroshilov almost 4 years ago

  • Target version set to 0.21
#7

Updated by Alexey Khoroshilov about 2 years ago

  • Status changed from Verified to Closed

Also available in: Atom PDF