Project

General

Profile

Bug #7418

Reset the state of the model before starting generating a new test program fle

Added by Andrei Tatarnikov almost 4 years ago. Updated 6 months ago.

Status:
Closed
Priority:
High
Category:
Test Engine
Target version:
Start date:
07/22/2016
Due date:
% Done:

0%

Estimated time:
Detected in build:
svn
Platform:
Published in build:

Description

When MicroTESK processes a test template, it may place the generated test cases into multiple files.
When generation of a new file starts, MicroTESK must reset the state of the model (registers and memory including all MMU buffers).

History

#1

Updated by Andrei Tatarnikov over 3 years ago

Registers and memory are reset. But MMU buffers still do not support this.

#2

Updated by Alexander Kamkin 6 months ago

  • Priority changed from Urgent to High
#3

Updated by Alexander Kamkin 6 months ago

  • Target version changed from 2.3 to 2.5
  • Category set to Test Engine
#4

Updated by Alexander Kamkin 6 months ago

  • Assignee changed from Andrei Tatarnikov to Alexander Kamkin
#5

Updated by Alexander Kamkin 6 months ago

  • Status changed from New to Closed

The state is reset. The problem is that MMU is not distributed among processing elements (all caches are global).

Also available in: Atom PDF