Project

General

Profile

Task #7378

NodeTransformer: multiple transform rules for a single enum id

Added by Sergey Smolov over 3 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Low
Category:
Transformer
Target version:
Start date:
07/06/2016
Due date:
% Done:

0%

Estimated time:
Detected in build:
svn
Published in build:

Description

See this:

public class NodeTransformer implements ExprTreeVisitor {
  // TODO use list of rules for enum as priority queue
  private final Map<Enum<?>, TransformerRule> ruleset;

Related issues

Related to Fortress - Task #5450: Support multiple rules per node in NodeTransformerClosed11/26/2014

Actions

History

#1

Updated by Sergey Smolov about 3 years ago

  • Priority changed from High to Low
#2

Updated by Artem Kotsynyak over 2 years ago

  • Status changed from New to Closed

Duplicate of #5450

Also available in: Atom PDF