Project

General

Profile

Bug #7377

При ручном вводе значения для атрибута типа BOOL таблица атрибутов зависает

Added by Viktoria Kopach over 4 years ago. Updated about 3 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Start date:
07/06/2016
Due date:
% Done:

100%

Estimated time:
Detected in build:
0.20.256
Platform:
Windows x64
Published in build:
0.21.287

Description

В таблице атрибутов у атрибута установить тип BOOL, кликнуть по ячейке Value и вместо выбора из списка ввести значение вручную (не важно, корректное или нет). Потом кликнуть куда-нибудь еще, чтобы сохранить изменения.
При этом режим редактирования этой ячейки не закроется, даже если кликать на другие вкладки окна Properties и обратно.
Если кликнуть на другой узел в Requality Explorer, то все содержимое таблицы изменится на соответствующее этому узлу, кроме таблицы атрибутов. Она останется прежней, для узла, у которого устанавливали атрибут типа BOOL.

Вот так будет это выглядеть:

Здесь курсор находится уже в другом поле (Name), но ячейка Value как будто все еще находится в режиме редактирования.

В Error log сыпятся ошибки:
eclipse.buildId=4.4.1.M20140925-0400
java.version=1.8.0_91
java.vendor=Oracle Corporation
BootLoader constants: OS=win32, ARCH=x86, WS=win32, NL=ru_RU
Framework arguments: -product org.eclipse.epp.package.standard.product
Command-line arguments: -os win32 -ws win32 -arch x86 -product org.eclipse.epp.package.standard.product

org.eclipse.ui
Error
Wed Jul 06 17:25:57 MSK 2016
Unhandled event loop exception

java.lang.ArrayIndexOutOfBoundsException: -1
at com.unitesk.requality.eclipse.views.atypeeditors.BoolValueEditor.doGetValue(BoolValueEditor.java:15)
at org.eclipse.jface.viewers.ComboBoxCellEditor.applyEditorValueAndDeactivate(ComboBoxCellEditor.java:257)
at org.eclipse.jface.viewers.ComboBoxCellEditor.focusLost(ComboBoxCellEditor.java:284)
at org.eclipse.jface.viewers.ComboBoxCellEditor$4.focusLost(ComboBoxCellEditor.java:173)
at org.eclipse.swt.widgets.TypedListener.handleEvent(TypedListener.java:143)
at org.eclipse.swt.widgets.EventTable.sendEvent(EventTable.java:84)
at org.eclipse.swt.widgets.Display.sendEvent(Display.java:4353)
at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1061)
at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1085)
at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1070)
at org.eclipse.swt.widgets.Widget.notifyListeners(Widget.java:782)
at org.eclipse.swt.custom.CCombo.handleFocus(CCombo.java:906)
at org.eclipse.swt.custom.CCombo$2.handleEvent(CCombo.java:147)
at org.eclipse.swt.widgets.EventTable.sendEvent(EventTable.java:84)
at org.eclipse.swt.widgets.Display.filterEvent(Display.java:1262)
at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1060)
at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1085)
at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1066)
at org.eclipse.swt.widgets.Control.sendFocusEvent(Control.java:2841)
at org.eclipse.swt.widgets.Widget.wmSetFocus(Widget.java:2425)
at org.eclipse.swt.widgets.Control.WM_SETFOCUS(Control.java:5236)
at org.eclipse.swt.widgets.Table.WM_SETFOCUS(Table.java:6309)
at org.eclipse.swt.widgets.Control.windowProc(Control.java:4680)
at org.eclipse.swt.widgets.Table.windowProc(Table.java:5939)
at org.eclipse.swt.widgets.Display.windowProc(Display.java:5023)
at org.eclipse.swt.internal.win32.OS.SetFocus(Native Method)
at org.eclipse.swt.widgets.Table.sendMouseDownEvent(Table.java:3866)
at org.eclipse.swt.widgets.Table.WM_LBUTTONDOWN(Table.java:6163)
at org.eclipse.swt.widgets.Control.windowProc(Control.java:4646)
at org.eclipse.swt.widgets.Table.windowProc(Table.java:5939)
at org.eclipse.swt.widgets.Display.windowProc(Display.java:5036)
at org.eclipse.swt.internal.win32.OS.DispatchMessageW(Native Method)
at org.eclipse.swt.internal.win32.OS.DispatchMessage(OS.java:2549)
at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:3759)
at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine$9.run(PartRenderingEngine.java:1151)
at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:332)
at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine.run(PartRenderingEngine.java:1032)
at org.eclipse.e4.ui.internal.workbench.E4Workbench.createAndRunUI(E4Workbench.java:148)
at org.eclipse.ui.internal.Workbench$5.run(Workbench.java:636)
at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:332)
at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Workbench.java:579)
at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.java:150)
at org.eclipse.ui.internal.ide.application.IDEApplication.start(IDEApplication.java:135)
at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:196)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:134)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:104)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:380)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:235)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
at java.lang.reflect.Method.invoke(Unknown Source)
at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:648)
at org.eclipse.equinox.launcher.Main.basicRun(Main.java:603)
at org.eclipse.equinox.launcher.Main.run(Main.java:1465)


eclipse.buildId=4.4.1.M20140925-0400
java.version=1.8.0_91
java.vendor=Oracle Corporation
BootLoader constants: OS=win32, ARCH=x86, WS=win32, NL=ru_RU
Framework arguments: -product org.eclipse.epp.package.standard.product
Command-line arguments: -os win32 -ws win32 -arch x86 -product org.eclipse.epp.package.standard.product

org.eclipse.ui
Error
Wed Jul 06 17:33:21 MSK 2016
Unhandled event loop exception

org.eclipse.swt.SWTException: Failed to execute runnable (java.lang.ArrayIndexOutOfBoundsException: -1)
at org.eclipse.swt.SWT.error(SWT.java:4441)
at org.eclipse.swt.SWT.error(SWT.java:4356)
at org.eclipse.swt.widgets.Synchronizer.runAsyncMessages(Synchronizer.java:139)
at org.eclipse.swt.widgets.Display.runAsyncMessages(Display.java:4147)
at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:3764)
at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine$9.run(PartRenderingEngine.java:1151)
at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:332)
at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine.run(PartRenderingEngine.java:1032)
at org.eclipse.e4.ui.internal.workbench.E4Workbench.createAndRunUI(E4Workbench.java:148)
at org.eclipse.ui.internal.Workbench$5.run(Workbench.java:636)
at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:332)
at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Workbench.java:579)
at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.java:150)
at org.eclipse.ui.internal.ide.application.IDEApplication.start(IDEApplication.java:135)
at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:196)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:134)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:104)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:380)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:235)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
at java.lang.reflect.Method.invoke(Unknown Source)
at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:648)
at org.eclipse.equinox.launcher.Main.basicRun(Main.java:603)
at org.eclipse.equinox.launcher.Main.run(Main.java:1465)
Caused by: java.lang.ArrayIndexOutOfBoundsException: -1
at com.unitesk.requality.eclipse.views.atypeeditors.BoolValueEditor.doGetValue(BoolValueEditor.java:15)
at org.eclipse.jface.viewers.CellEditor.getValue(CellEditor.java:486)
at org.eclipse.jface.viewers.EditingSupport.saveCellEditorValue(EditingSupport.java:112)
at org.eclipse.jface.viewers.ColumnViewerEditor.saveEditorValue(ColumnViewerEditor.java:463)
at org.eclipse.jface.viewers.ColumnViewerEditor.applyEditorValue(ColumnViewerEditor.java:319)
at org.eclipse.jface.viewers.ColumnViewer.applyEditorValue(ColumnViewer.java:394)
at org.eclipse.jface.viewers.AbstractTableViewer.internalRefresh(AbstractTableViewer.java:612)
at org.eclipse.jface.viewers.AbstractTableViewer.internalRefresh(AbstractTableViewer.java:607)
at org.eclipse.jface.viewers.AbstractTableViewer$1.run(AbstractTableViewer.java:567)
at org.eclipse.jface.viewers.StructuredViewer.preservingSelection(StructuredViewer.java:1436)
at org.eclipse.jface.viewers.StructuredViewer.preservingSelection(StructuredViewer.java:1397)
at org.eclipse.jface.viewers.AbstractTableViewer.inputChanged(AbstractTableViewer.java:564)
at org.eclipse.jface.viewers.ContentViewer.setInput(ContentViewer.java:292)
at org.eclipse.jface.viewers.StructuredViewer.setInput(StructuredViewer.java:1675)
at com.unitesk.requality.eclipse.views.properties.AttributesPanel.setNode(AttributesPanel.java:1538)
at com.unitesk.requality.eclipse.views.properties.MainPropertySection.setTreeNode(MainPropertySection.java:251)
at com.unitesk.requality.eclipse.views.properties.TreeNodePropertiesTab$2.run(TreeNodePropertiesTab.java:234)
at org.eclipse.swt.widgets.RunnableLock.run(RunnableLock.java:35)
at org.eclipse.swt.widgets.Synchronizer.runAsyncMessages(Synchronizer.java:136)
... 23 more


Files

2016-07-06_1731.png (15.2 KB) 2016-07-06_1731.png Viktoria Kopach, 07/06/2016 05:32 PM

History

#1

Updated by Denis Kildishev almost 4 years ago

связанная ошибка

!ENTRY org.eclipse.ui 4 0 2017-01-09 12:10:41.992
!MESSAGE Unhandled event loop exception
!STACK 0
java.lang.ArrayIndexOutOfBoundsException: -1
at com.unitesk.requality.eclipse.views.atypeeditors.BoolValueEditor.doGetValue(BoolValueEditor.java:15)
at org.eclipse.jface.viewers.ComboBoxCellEditor.applyEditorValueAndDeactivate(ComboBoxCellEditor.java:252)
at org.eclipse.jface.viewers.ComboBoxCellEditor.focusLost(ComboBoxCellEditor.java:279)
at org.eclipse.jface.viewers.ComboBoxCellEditor$3.focusLost(ComboBoxCellEditor.java:168)
at org.eclipse.swt.widgets.TypedListener.handleEvent(TypedListener.java:144)
at org.eclipse.swt.widgets.EventTable.sendEvent(EventTable.java:84)
at org.eclipse.swt.widgets.Display.sendEvent(Display.java:5219)
at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1340)
at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1366)
at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1349)
at org.eclipse.swt.widgets.Widget.notifyListeners(Widget.java:1134)
at org.eclipse.swt.custom.CCombo.handleFocus(CCombo.java:922)
at org.eclipse.swt.custom.CCombo$2.handleEvent(CCombo.java:150)
at org.eclipse.swt.widgets.EventTable.sendEvent(EventTable.java:84)
at org.eclipse.swt.widgets.Display.filterEvent(Display.java:1605)
at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1339)
at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1366)
at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1345)
at org.eclipse.swt.widgets.Control.sendFocusEvent(Control.java:4061)
at org.eclipse.swt.widgets.Control.gtk_event_after(Control.java:3333)
at org.eclipse.swt.widgets.Table.gtk_event_after(Table.java:2061)
at org.eclipse.swt.widgets.Widget.windowProc(Widget.java:1986)
at org.eclipse.swt.widgets.Control.windowProc(Control.java:5819)
at org.eclipse.swt.widgets.Table.windowProc(Table.java:3845)
at org.eclipse.swt.widgets.Display.windowProc(Display.java:5490)
at org.eclipse.swt.internal.gtk.OS._gtk_main_do_event(Native Method)
at org.eclipse.swt.internal.gtk.OS.gtk_main_do_event(OS.java:9555)
at org.eclipse.swt.widgets.Display.eventProc(Display.java:1275)
at org.eclipse.swt.internal.gtk.OS._g_main_context_iteration(Native Method)
at org.eclipse.swt.internal.gtk.OS.g_main_context_iteration(OS.java:2495)
at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:4141)
at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine$4.run(PartRenderingEngine.java:1121)
at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:336)
at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine.run(PartRenderingEngine.java:1022)
at org.eclipse.e4.ui.internal.workbench.E4Workbench.createAndRunUI(E4Workbench.java:150)
at org.eclipse.ui.internal.Workbench$5.run(Workbench.java:687)
at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:336)
at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Workbench.java:604)
at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.java:148)
at org.eclipse.ui.internal.ide.application.IDEApplication.start(IDEApplication.java:138)
at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:196)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:134)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:104)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:388)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:243)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
at java.lang.reflect.Method.invoke(Method.java:498)
at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:673)
at org.eclipse.equinox.launcher.Main.basicRun(Main.java:610)
at org.eclipse.equinox.launcher.Main.run(Main.java:1519)
at org.eclipse.equinox.launcher.Main.main(Main.java:1492)

#2

Updated by Denis Kildishev almost 4 years ago

  • Status changed from New to Resolved
  • % Done changed from 0 to 100

Applied in changeset r5418.

#3

Updated by Denis Kildishev almost 4 years ago

  • Published in build set to 0.21.287
#4

Updated by Viktoria Kopach almost 4 years ago

  • Status changed from Resolved to Verified

В поле теперь нельзя вводить значение в ручную. Можно только выбирать из списка.

#5

Updated by Alexey Khoroshilov almost 4 years ago

  • Target version set to 0.21
#6

Updated by Denis Kildishev about 3 years ago

  • Status changed from Verified to Resolved

Applied in changeset requality|commit:947b37484881e8ea7c1bfb3cf328b122617dc0b3.

#7

Updated by Alexey Khoroshilov about 3 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF