Project

General

Profile

Bug #6715

Automatic update of page is incomplete

Added by Evgeny Novikov about 4 years ago. Updated almost 3 years ago.

Status:
Closed
Priority:
High
Category:
Bridge
Target version:
-
Start date:
02/02/2016
Due date:
% Done:

100%

Estimated time:
Detected in build:
svn
Platform:
Published in build:

Description

When the job page is automatically updated, the number of unknowns with associated marks can late in comparison with the total number of unknowns.


Related issues

Blocks Klever - Feature #6677: Dynamically update component pagesNew02/01/2016

Actions

History

#1

Updated by Vladimir Gratinskiy almost 4 years ago

It is not a bug. The time between calculating total number of unknowns and associations with marks is not a zero. Synchronization of browser and server could happen even between saving values to the database. You should accept that the world is not ideal and we still don't have quantum computer.

#2

Updated by Evgeny Novikov almost 4 years ago

But why not synchronize getting and setting of data chunks for which this has sense? You likely can use the standard approach for locking. Besides you will need just to specify separate functions working with corresponding data chunks.

#3

Updated by Vladimir Gratinskiy about 3 years ago

  • Status changed from New to Resolved
  • % Done changed from 0 to 100

Should be fixed in branch "bridge-logs" as updating job's statistic and uploading report (where unknown report is uploaded and cache is recalculated after unknown was marked automatically) can't be executed in parallel.

#4

Updated by Evgeny Novikov almost 3 years ago

  • Status changed from Resolved to Closed

I merge the branch to master in 3f0ad507.

Also available in: Atom PDF