Project

General

Profile

Bug #6292

NPE in CfgInterfaceExtractorTestCase

Added by Igor Melnichenko about 5 years ago. Updated about 5 years ago.

Status:
Closed
Priority:
Low
Assignee:
Category:
Engine (Parser)
Target version:
Start date:
09/27/2015
Due date:
% Done:

0%

Estimated time:
Detected in build:
svn
Platform:
Windows x64
Published in build:

Description

2015.09.27 16:29:49.353. INFO: Retrascope is starting
2015.09.27 16:29:49.353. INFO: Running: vhdl-parser

2015.09.27 16:29:49.353. INFO: Options: {args=C:\workspaces\ispras\retrascope\src\test\vhdl\itc99-poli2\b10\b10.vhd --target cfg-iface --toplevel b10 , vhd=[C:\workspaces\ispras\retrascope\src\test\vhdl\itc99-poli2\b10\b10.vhd]}

2015.09.27 16:29:49.363. ERROR: The exception has been encountered: java.lang.NullPointerException
at org.zamia.zdb.ZDB$BaosToDiskThread.readObject(ZDB.java:607)
at org.zamia.zdb.ZDB.load(ZDB.java:729)
at org.zamia.zdb.ZDB.getIdxObj(ZDB.java:849)
at org.zamia.DMManager.getLibrary(DMManager.java:372)
at org.zamia.DMManager.addDesignUnitSource(DMManager.java:402)
at org.zamia.vhdl.VHDLIndexer.packageDeclaration(VHDLIndexer.java:188)
at org.zamia.vhdl.VHDLIndexer.parse(VHDLIndexer.java:248)
at org.zamia.DMManager.indexFile(DMManager.java:271)
at org.zamia.DMManager.indexStdLib(DMManager.java:287)
at org.zamia.DMManager.indexStdLibs(DMManager.java:306)
at org.zamia.DMManager.<init>(DMManager.java:109)
at org.zamia.ZamiaProject.<init>(ZamiaProject.java:130)
at org.zamia.ZamiaProject.<init>(ZamiaProject.java:97)
at org.zamia.ZamiaProject.<init>(ZamiaProject.java:167)
at ru.ispras.retrascope.parser.vhdl.VhdlParser.parse(VhdlParser.java:134)
at ru.ispras.retrascope.parser.basis.HdlParser.start(HdlParser.java:73)
at ru.ispras.retrascope.basis.Engine.start(Engine.java:200)
at ru.ispras.retrascope.basis.ToolChain.start(ToolChain.java:102)
at ru.ispras.retrascope.basis.Engine.start(Engine.java:200)
at ru.ispras.retrascope.Retrascope$ToolRun.start(Retrascope.java:197)
at ru.ispras.retrascope.Retrascope.main(Retrascope.java:380)
at ru.ispras.retrascope.Retrascope.main(Retrascope.java:397)
at ru.ispras.retrascope.util.VhdlUtilTest.runRetrascope(VhdlUtilTest.java:169)
at ru.ispras.retrascope.util.VhdlUtilTest.runVhdl(VhdlUtilTest.java:65)
at ru.ispras.retrascope.util.VhdlUtilTest.runVhdl(VhdlUtilTest.java:47)
at ru.ispras.retrascope.util.HdlUtilTest.runVhdl(HdlUtilTest.java:73)
at ru.ispras.retrascope.util.HdlUtilTest.runHdl(HdlUtilTest.java:40)
at ru.ispras.retrascope.engine.cfg.extractor.iface.CfgInterfaceExtractorTestCase.runTest(CfgInterfaceExtractorTestCase.java:37)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
at java.lang.reflect.Method.invoke(Method.java:497)
at org.junit.runners.model.FrameworkMethod$1.runReflectiveCall(FrameworkMethod.java:44)
at org.junit.internal.runners.model.ReflectiveCallable.run(ReflectiveCallable.java:15)
at org.junit.runners.model.FrameworkMethod.invokeExplosively(FrameworkMethod.java:41)
at org.junit.internal.runners.statements.InvokeMethod.evaluate(InvokeMethod.java:20)
at org.junit.runners.BlockJUnit4ClassRunner.runChild(BlockJUnit4ClassRunner.java:76)
at org.junit.runners.BlockJUnit4ClassRunner.runChild(BlockJUnit4ClassRunner.java:50)
at org.junit.runners.ParentRunner$3.run(ParentRunner.java:193)
at org.junit.runners.ParentRunner$1.schedule(ParentRunner.java:52)
at org.junit.runners.ParentRunner.runChildren(ParentRunner.java:191)
at org.junit.runners.ParentRunner.access$000(ParentRunner.java:42)
at org.junit.runners.ParentRunner$2.evaluate(ParentRunner.java:184)
at org.junit.runners.ParentRunner.run(ParentRunner.java:236)
at org.gradle.api.internal.tasks.testing.junit.JUnitTestClassExecuter.runTestClass(JUnitTestClassExecuter.java:105)
at org.gradle.api.internal.tasks.testing.junit.JUnitTestClassExecuter.execute(JUnitTestClassExecuter.java:56)
at org.gradle.api.internal.tasks.testing.junit.JUnitTestClassProcessor.processTestClass(JUnitTestClassProcessor.java:64)
at org.gradle.api.internal.tasks.testing.SuiteTestClassProcessor.processTestClass(SuiteTestClassProcessor.java:50)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
at java.lang.reflect.Method.invoke(Method.java:497)
at org.gradle.messaging.dispatch.ReflectionDispatch.dispatch(ReflectionDispatch.java:35)
at org.gradle.messaging.dispatch.ReflectionDispatch.dispatch(ReflectionDispatch.java:24)
at org.gradle.messaging.dispatch.ContextClassLoaderDispatch.dispatch(ContextClassLoaderDispatch.java:32)
at org.gradle.messaging.dispatch.ProxyDispatchAdapter$DispatchingInvocationHandler.invoke(ProxyDispatchAdapter.java:93)
at com.sun.proxy.$Proxy2.processTestClass(Unknown Source)
at org.gradle.api.internal.tasks.testing.worker.TestWorker.processTestClass(TestWorker.java:106)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
at java.lang.reflect.Method.invoke(Method.java:497)
at org.gradle.messaging.dispatch.ReflectionDispatch.dispatch(ReflectionDispatch.java:35)
at org.gradle.messaging.dispatch.ReflectionDispatch.dispatch(ReflectionDispatch.java:24)
at org.gradle.messaging.remote.internal.hub.MessageHub$Handler.run(MessageHub.java:360)
at org.gradle.internal.concurrent.ExecutorPolicy$CatchAndRecordFailures.onExecute(ExecutorPolicy.java:54)
at org.gradle.internal.concurrent.StoppableExecutorImpl$1.run(StoppableExecutorImpl.java:40)
at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)
at java.lang.Thread.run(Thread.java:745)

History

#1

Updated by Igor Melnichenko about 5 years ago

  • Priority changed from Normal to Low

When Eclipse has been restarted, this test has been successfully passed so it's a sort of environmental issue.
I lower this ticket's priority but I think some investigation would be useful to ensure that the issue isn't caused by Retrascope behaviour.

#2

Updated by Sergey Smolov about 5 years ago

Have you used this Zamia installation instruction: http://forge.ispras.ru/projects/retrascope/wiki/Installation_Guide ?
Especially, this point:

4. For VHDL designs elaboration:
  a) Set @ZAMIA_LOCKING@ system environment variable to @true@.

Which version of Java/Eclipse do you use?

#3

Updated by Sergey Smolov about 5 years ago

  • Status changed from New to Feedback
#4

Updated by Igor Melnichenko about 5 years ago

Sergey Smolov wrote:

Have you used this Zamia installation instruction: http://forge.ispras.ru/projects/retrascope/wiki/Installation_Guide ?
Especially, this point:
[...]
Which version of Java/Eclipse do you use?

No, I missed it. May I add this declaration to test configuration of build.gradle?
JDK 1.7.0_80/Eclipse 4.5.

#5

Updated by Sergey Smolov about 5 years ago

Igor Melnichenko wrote:

Sergey Smolov wrote:

Have you used this Zamia installation instruction: http://forge.ispras.ru/projects/retrascope/wiki/Installation_Guide ?
Especially, this point:
[...]

No, I missed it. May I add this declaration to test configuration of build.gradle?

Sure.

#6

Updated by Sergey Smolov about 5 years ago

  • Status changed from Feedback to Open
#7

Updated by Igor Melnichenko about 5 years ago

  • Status changed from Open to Closed

Also available in: Atom PDF