Project

General

Profile

Bug #6281

EfsmTestGeneratorVhdlTestCase: Efsm.UNINITIALISED_STATE isn't supported yet

Added by Sergey Smolov about 4 years ago. Updated almost 4 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Engine (Transformer)
Target version:
Start date:
09/17/2015
Due date:
% Done:

100%

Estimated time:
Detected in build:
svn
Platform:
Published in build:
0.2.1

Description

2015.09.17 14:33:54.526. INFO: Retrascope is starting
2015.09.17 14:33:54.526. INFO: Running: vhdl-parser

2015.09.17 14:33:54.526. INFO: Options: {args=/home/ssedai/projects/retrascope.svn/src/test/vhdl/sample/sample.vhd --target test --toplevel sample --engine efsm-test-generator --loop-limit 25, vhd=[/home/ssedai/projects/retrascope.svn/src/test/vhdl/sample/sample.vhd]}

2015.09.17 14:33:54.683. INFO: Storing: cfg

2015.09.17 14:33:54.683. INFO: Running: cfg-cgaa-transformer

2015.09.17 14:33:54.683. INFO: Options: {args=/home/ssedai/projects/retrascope.svn/src/test/vhdl/sample/sample.vhd --target test --toplevel sample --engine efsm-test-generator --loop-limit 25, cfg=<cfg>}

2015.09.17 14:33:54.683. INFO: Storing: cgaa

2015.09.17 14:33:54.683. INFO: Running: cgaa-efsm-transformer

2015.09.17 14:33:54.683. INFO: Options: {cgaa=<cgaa>, args=/home/ssedai/projects/retrascope.svn/src/test/vhdl/sample/sample.vhd --target test --toplevel sample --engine efsm-test-generator --loop-limit 25}

2015.09.17 14:33:54.878. INFO: Number of GADD paths: 5
2015.09.17 14:33:54.878. INFO: ======================================
2015.09.17 14:33:54.878. INFO: Clock-like variables: [CLK, RST].
2015.09.17 14:33:54.878. INFO: Transforming the process of module: SAMPLE.
2015.09.17 14:33:54.878. INFO: 1 states are extracted.
2015.09.17 14:33:54.878. INFO: The state-like variables are: [].
2015.09.17 14:33:54.977. INFO: 3 transitions are extracted.
2015.09.17 14:33:54.977. INFO: 1 EFSM(s) are extracted.
2015.09.17 14:33:54.978. INFO: Storing: efsm

2015.09.17 14:33:54.978. INFO: Running: efsm-test-generator

2015.09.17 14:33:54.978. INFO: Options: {efsm=<efsm>, args=/home/ssedai/projects/retrascope.svn/src/test/vhdl/sample/sample.vhd --target test --toplevel sample --engine efsm-test-generator --loop-limit 25}

2015.09.17 14:33:54.978. INFO: EFSM.TestGenerator: module SAMPLE: starting test generation
2015.09.17 14:33:54.978. ERROR: The exception has been encountered: ru.ispras.retrascope.basis.exception.RetrascopeRuntimeException: Efsm.UNINITIALISED_STATE isn't supported yet
    at ru.ispras.retrascope.engine.efsm.simulator.ProcessSimulator.reset(ProcessSimulator.java:169)
    at ru.ispras.retrascope.engine.efsm.simulator.ProcessSimulator.<init>(ProcessSimulator.java:110)
    at ru.ispras.retrascope.engine.efsm.simulator.ModuleSimulator.<init>(ModuleSimulator.java:81)
    at ru.ispras.retrascope.engine.efsm.generator.test.Generator.<init>(Generator.java:75)
    at ru.ispras.retrascope.engine.efsm.generator.test.EfsmTestGenerator.start(EfsmTestGenerator.java:124)
    at ru.ispras.retrascope.engine.efsm.generator.test.EfsmTestGenerator.start(EfsmTestGenerator.java:53)
    at ru.ispras.retrascope.basis.Engine.start(Engine.java:200)
    at ru.ispras.retrascope.basis.ToolChain.start(ToolChain.java:102)
    at ru.ispras.retrascope.basis.Engine.start(Engine.java:200)
    at ru.ispras.retrascope.Retrascope$ToolRun.start(Retrascope.java:197)
    at ru.ispras.retrascope.Retrascope.main(Retrascope.java:380)
    at ru.ispras.retrascope.Retrascope.main(Retrascope.java:397)
    at ru.ispras.retrascope.util.VhdlUtilTest.runRetrascope(VhdlUtilTest.java:169)
    at ru.ispras.retrascope.util.VhdlUtilTest.runVhdl(VhdlUtilTest.java:81)
    at ru.ispras.retrascope.util.HdlUtilTest.runVhdl(HdlUtilTest.java:97)
    at ru.ispras.retrascope.engine.efsm.generator.test.EfsmTestGeneratorVhdlTestCase.generate(EfsmTestGeneratorVhdlTestCase.java:35)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
    at java.lang.reflect.Method.invoke(Method.java:606)
    at org.junit.runners.model.FrameworkMethod$1.runReflectiveCall(FrameworkMethod.java:44)
    at org.junit.internal.runners.model.ReflectiveCallable.run(ReflectiveCallable.java:15)
    at org.junit.runners.model.FrameworkMethod.invokeExplosively(FrameworkMethod.java:41)
    at org.junit.internal.runners.statements.InvokeMethod.evaluate(InvokeMethod.java:20)
    at org.junit.runners.BlockJUnit4ClassRunner.runChild(BlockJUnit4ClassRunner.java:76)
    at org.junit.runners.BlockJUnit4ClassRunner.runChild(BlockJUnit4ClassRunner.java:50)
    at org.junit.runners.ParentRunner$3.run(ParentRunner.java:193)
    at org.junit.runners.ParentRunner$1.schedule(ParentRunner.java:52)
    at org.junit.runners.ParentRunner.runChildren(ParentRunner.java:191)
    at org.junit.runners.ParentRunner.access$000(ParentRunner.java:42)
    at org.junit.runners.ParentRunner$2.evaluate(ParentRunner.java:184)
    at org.junit.runners.ParentRunner.run(ParentRunner.java:236)
    at org.gradle.api.internal.tasks.testing.junit.JUnitTestClassExecuter.runTestClass(JUnitTestClassExecuter.java:86)
    at org.gradle.api.internal.tasks.testing.junit.JUnitTestClassExecuter.execute(JUnitTestClassExecuter.java:49)
    at org.gradle.api.internal.tasks.testing.junit.JUnitTestClassProcessor.processTestClass(JUnitTestClassProcessor.java:64)
    at org.gradle.api.internal.tasks.testing.SuiteTestClassProcessor.processTestClass(SuiteTestClassProcessor.java:50)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
    at java.lang.reflect.Method.invoke(Method.java:606)
    at org.gradle.messaging.dispatch.ReflectionDispatch.dispatch(ReflectionDispatch.java:35)
    at org.gradle.messaging.dispatch.ReflectionDispatch.dispatch(ReflectionDispatch.java:24)
    at org.gradle.messaging.dispatch.ContextClassLoaderDispatch.dispatch(ContextClassLoaderDispatch.java:32)
    at org.gradle.messaging.dispatch.ProxyDispatchAdapter$DispatchingInvocationHandler.invoke(ProxyDispatchAdapter.java:93)
    at com.sun.proxy.$Proxy2.processTestClass(Unknown Source)
    at org.gradle.api.internal.tasks.testing.worker.TestWorker.processTestClass(TestWorker.java:106)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
    at java.lang.reflect.Method.invoke(Method.java:606)
    at org.gradle.messaging.dispatch.ReflectionDispatch.dispatch(ReflectionDispatch.java:35)
    at org.gradle.messaging.dispatch.ReflectionDispatch.dispatch(ReflectionDispatch.java:24)
    at org.gradle.messaging.remote.internal.hub.MessageHub$Handler.run(MessageHub.java:360)
    at org.gradle.internal.concurrent.DefaultExecutorFactory$StoppableExecutorImpl$1.run(DefaultExecutorFactory.java:64)
    at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)
    at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
    at java.lang.Thread.run(Thread.java:744)

2015.09.17 14:33:54.980. INFO: Retrascope is shutting down

History

#1

Updated by Igor Melnichenko about 4 years ago

  • Status changed from New to Feedback

In case of sample.vhd, the expected states in EFSM would be state = 0 and state = 1 but debug information shows that Efsm.states = [false, true] and Efsm.initialState = false (which is reserved value for uninitialised state in Verilog designs).

#2

Updated by Sergey Smolov about 4 years ago

  • Status changed from Feedback to Open

Wow, I can't reproduce this bug:-) May be this is already fixed somehow?
If you don't get this error too, we can reject this bug.

#3

Updated by Igor Melnichenko about 4 years ago

There's something strange here. I have two test results in Gradle:
1) if I run solely EfsmTestGeneratorVhdlTestCase, no exceptions occur;
2) if I run all tests, the reported exception occurs.

#4

Updated by Sergey Smolov about 4 years ago

  • Category changed from Engine (Simulator) to Engine (Transformer)
  • Assignee changed from Igor Melnichenko to Sergey Smolov
#5

Updated by Sergey Smolov about 4 years ago

  • Status changed from Open to Resolved
  • % Done changed from 0 to 100

Done in r2359.

#6

Updated by Igor Melnichenko about 4 years ago

  • Status changed from Resolved to Verified
#7

Updated by Sergey Smolov almost 4 years ago

  • Status changed from Verified to Closed
  • Published in build set to 0.2.1

Also available in: Atom PDF