Project

General

Profile

Bug #6280

TestVhdlTestbenchPrinterVhdlTestCase: The exception has occurred while printing test pattern file

Added by Sergey Smolov about 5 years ago. Updated over 4 years ago.

Status:
Closed
Priority:
Normal
Category:
Engine (Printer)
Target version:
Start date:
09/17/2015
Due date:
% Done:

100%

Estimated time:
Detected in build:
svn
Platform:
Published in build:
0.2.1

Description

2015.09.17 14:21:04.246. INFO: Retrascope is starting
2015.09.17 14:21:04.246. INFO: Running: vhdl-parser

2015.09.17 14:21:04.246. INFO: Options: {args=/home/ssedai/projects/retrascope.svn/src/test/vhdl/sample/sample.vhd --target vhdl-testbench --toplevel sample --engine efsm-test-generator --loop-limit 25, vhd=[/home/ssedai/projects/retrascope.svn/src/test/vhdl/sample/sample.vhd]}

2015.09.17 14:21:04.436. INFO: Storing: cfg

2015.09.17 14:21:04.436. INFO: Running: cfg-cfginterface-extractor

2015.09.17 14:21:04.436. INFO: Options: {args=/home/ssedai/projects/retrascope.svn/src/test/vhdl/sample/sample.vhd --target vhdl-testbench --toplevel sample --engine efsm-test-generator --loop-limit 25, cfg=<cfg>}

2015.09.17 14:21:04.436. INFO: Storing: cfg-iface

2015.09.17 14:21:04.436. INFO: Running: cfg-cgaa-transformer

2015.09.17 14:21:04.436. INFO: Options: {args=/home/ssedai/projects/retrascope.svn/src/test/vhdl/sample/sample.vhd --target vhdl-testbench --toplevel sample --engine efsm-test-generator --loop-limit 25, cfg=<cfg>}

2015.09.17 14:21:04.437. INFO: Storing: cgaa

2015.09.17 14:21:04.437. INFO: Running: cgaa-efsm-transformer

2015.09.17 14:21:04.437. INFO: Options: {cgaa=<cgaa>, args=/home/ssedai/projects/retrascope.svn/src/test/vhdl/sample/sample.vhd --target vhdl-testbench --toplevel sample --engine efsm-test-generator --loop-limit 25}

2015.09.17 14:21:04.739. INFO: Number of GADD paths: 5
2015.09.17 14:21:04.740. INFO: ======================================
2015.09.17 14:21:04.740. INFO: Clock-like variables: [CLK, RST].
2015.09.17 14:21:04.740. INFO: Transforming the process of module: SAMPLE.
2015.09.17 14:21:04.859. INFO: 2 states are extracted.
2015.09.17 14:21:04.859. INFO: The state-like variables are: [STATE].
2015.09.17 14:21:05.159. INFO: 4 transitions are extracted.
2015.09.17 14:21:05.196. INFO: 1 EFSM(s) are extracted.
2015.09.17 14:21:05.196. INFO: Storing: efsm

2015.09.17 14:21:05.197. INFO: Running: efsm-test-generator

2015.09.17 14:21:05.197. INFO: Options: {efsm=<efsm>, args=/home/ssedai/projects/retrascope.svn/src/test/vhdl/sample/sample.vhd --target vhdl-testbench --toplevel sample --engine efsm-test-generator --loop-limit 25}

2015.09.17 14:21:05.197. INFO: EFSM.TestGenerator: module SAMPLE: starting test generation
2015.09.17 14:21:05.859. INFO: EFSM.TestGenerator: module SAMPLE: test generation has been finished successfully
2015.09.17 14:21:05.859. INFO: EFSM.TestGenerator: module SAMPLE: test coverage: 100% (4 of 4 transitions)
2015.09.17 14:21:05.859. INFO: EFSM.TestGenerator: module SAMPLE: amount of tests: 1
2015.09.17 14:21:05.859. INFO: EFSM.TestGenerator: module SAMPLE: amount of vectors: 0
2015.09.17 14:21:05.859. INFO: Storing: test

2015.09.17 14:21:05.860. INFO: Running: test-vhdl-testbench-printer

2015.09.17 14:21:05.860. INFO: Options: {test=<test>, cfg-iface=<cfg-iface>, args=/home/ssedai/projects/retrascope.svn/src/test/vhdl/sample/sample.vhd --target vhdl-testbench --toplevel sample --engine efsm-test-generator --loop-limit 25}

2015.09.17 14:21:05.864. ERROR: The exception has been encountered: ru.ispras.retrascope.basis.exception.RetrascopeRuntimeException: The exception has occurred while printing test pattern file
    at ru.ispras.retrascope.engine.test.printer.testbench.vhdl.TestVhdlTestbenchPrinter.printTestbench(TestVhdlTestbenchPrinter.java:292)
    at ru.ispras.retrascope.engine.test.printer.testbench.vhdl.TestVhdlTestbenchPrinter.start(TestVhdlTestbenchPrinter.java:235)
    at ru.ispras.retrascope.engine.test.printer.testbench.vhdl.TestVhdlTestbenchPrinter.start(TestVhdlTestbenchPrinter.java:69)
    at ru.ispras.retrascope.basis.Engine.start(Engine.java:200)
    at ru.ispras.retrascope.basis.ToolChain.start(ToolChain.java:102)
    at ru.ispras.retrascope.basis.Engine.start(Engine.java:200)
    at ru.ispras.retrascope.Retrascope$ToolRun.start(Retrascope.java:197)
    at ru.ispras.retrascope.Retrascope.main(Retrascope.java:380)
    at ru.ispras.retrascope.Retrascope.main(Retrascope.java:397)
    at ru.ispras.retrascope.util.VhdlUtilTest.runRetrascope(VhdlUtilTest.java:169)
    at ru.ispras.retrascope.util.VhdlUtilTest.runVhdl(VhdlUtilTest.java:81)
    at ru.ispras.retrascope.util.HdlUtilTest.runVhdl(HdlUtilTest.java:97)
    at ru.ispras.retrascope.engine.test.printer.testbench.vhdl.TestVhdlTestbenchPrinterVhdlTestCase.generate(TestVhdlTestbenchPrinterVhdlTestCase.java:39)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
    at java.lang.reflect.Method.invoke(Method.java:606)
    at org.junit.runners.model.FrameworkMethod$1.runReflectiveCall(FrameworkMethod.java:44)
    at org.junit.internal.runners.model.ReflectiveCallable.run(ReflectiveCallable.java:15)
    at org.junit.runners.model.FrameworkMethod.invokeExplosively(FrameworkMethod.java:41)
    at org.junit.internal.runners.statements.InvokeMethod.evaluate(InvokeMethod.java:20)
    at org.junit.runners.BlockJUnit4ClassRunner.runChild(BlockJUnit4ClassRunner.java:76)
    at org.junit.runners.BlockJUnit4ClassRunner.runChild(BlockJUnit4ClassRunner.java:50)
    at org.junit.runners.ParentRunner$3.run(ParentRunner.java:193)
    at org.junit.runners.ParentRunner$1.schedule(ParentRunner.java:52)
    at org.junit.runners.ParentRunner.runChildren(ParentRunner.java:191)
    at org.junit.runners.ParentRunner.access$000(ParentRunner.java:42)
    at org.junit.runners.ParentRunner$2.evaluate(ParentRunner.java:184)
    at org.junit.runners.ParentRunner.run(ParentRunner.java:236)
    at org.gradle.api.internal.tasks.testing.junit.JUnitTestClassExecuter.runTestClass(JUnitTestClassExecuter.java:86)
    at org.gradle.api.internal.tasks.testing.junit.JUnitTestClassExecuter.execute(JUnitTestClassExecuter.java:49)
    at org.gradle.api.internal.tasks.testing.junit.JUnitTestClassProcessor.processTestClass(JUnitTestClassProcessor.java:64)
    at org.gradle.api.internal.tasks.testing.SuiteTestClassProcessor.processTestClass(SuiteTestClassProcessor.java:50)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
    at java.lang.reflect.Method.invoke(Method.java:606)
    at org.gradle.messaging.dispatch.ReflectionDispatch.dispatch(ReflectionDispatch.java:35)
    at org.gradle.messaging.dispatch.ReflectionDispatch.dispatch(ReflectionDispatch.java:24)
    at org.gradle.messaging.dispatch.ContextClassLoaderDispatch.dispatch(ContextClassLoaderDispatch.java:32)
    at org.gradle.messaging.dispatch.ProxyDispatchAdapter$DispatchingInvocationHandler.invoke(ProxyDispatchAdapter.java:93)
    at com.sun.proxy.$Proxy2.processTestClass(Unknown Source)
    at org.gradle.api.internal.tasks.testing.worker.TestWorker.processTestClass(TestWorker.java:106)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
    at java.lang.reflect.Method.invoke(Method.java:606)
    at org.gradle.messaging.dispatch.ReflectionDispatch.dispatch(ReflectionDispatch.java:35)
    at org.gradle.messaging.dispatch.ReflectionDispatch.dispatch(ReflectionDispatch.java:24)
    at org.gradle.messaging.remote.internal.hub.MessageHub$Handler.run(MessageHub.java:360)
    at org.gradle.internal.concurrent.DefaultExecutorFactory$StoppableExecutorImpl$1.run(DefaultExecutorFactory.java:64)
    at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)
    at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
    at java.lang.Thread.run(Thread.java:744)
Caused by: java.nio.file.FileAlreadyExistsException: The specified file already exists: testbenches/SAMPLE/SAMPLE_test.tst
    at ru.ispras.retrascope.engine.test.printer.testbench.DeciderLikeTestPatternPrinter.print(DeciderLikeTestPatternPrinter.java:63)
    at ru.ispras.retrascope.engine.test.printer.testbench.vhdl.TestVhdlTestbenchPrinter.printTestbench(TestVhdlTestbenchPrinter.java:290)
    ... 53 more

2015.09.17 14:21:05.865. INFO: Retrascope is shutting down

History

#1

Updated by Igor Melnichenko almost 5 years ago

  • Status changed from New to Resolved
  • % Done changed from 0 to 100
#2

Updated by Sergey Smolov almost 5 years ago

  • Status changed from Resolved to Verified
#3

Updated by Sergey Smolov almost 5 years ago

  • Subject changed from ru.ispras.retrascope.engine.test.printer.testbench.vhdl.TestVhdlTestbenchPrinterVhdlTestCase: RetrascopeRuntimeException: The exception has occurred while printing test pattern file to TestVhdlTestbenchPrinterVhdlTestCase: The exception has occurred while printing test pattern file
#4

Updated by Sergey Smolov over 4 years ago

  • Status changed from Verified to Closed
  • Published in build set to 0.2.1

Also available in: Atom PDF