Project

General

Profile

Bug #5684

computeExpression -> LOGIC_BOOLEAN vs (MAP LOGIC_INTEGER LOGIC_BOOLEAN)

Added by Sergey Smolov over 5 years ago. Updated about 3 years ago.

Status:
Rejected
Priority:
Low
Category:
Engine (Simulator)
Target version:
Start date:
03/04/2015
Due date:
% Done:

0%

Estimated time:
Detected in build:
master
Platform:
Published in build:

Description

I've tried to add the "example" project to the Retrascope's test suite (in fact, I've tried to uncomment corresponding lines in the VhdlFiles class).
Upon "test.vhd" I've got an error.

Tool arguments: src/test/vhdl/example/test.vhd --target test --toplevel test --engine efsm-test-generator

Error log:

2015.03.04 17:04:41.337. INFO: EFSM.TestGenerator: starting a new sequence
2015.03.04 17:04:41.338. INFO: EFSM.Simulator.WORK.TEST(BEHAVIORAL)_0: resetting EFSM
2015.03.04 17:04:41.338. INFO: EFSM.TestGenerator.RandomGenerator.WORK.TEST(BEHAVIORAL)_0: generating a new input vector
2015.03.04 17:04:41.339. INFO: EFSM.TestGenerator.RandomGenerator.WORK.TEST(BEHAVIORAL)_0: resetting the EFSM
2015.03.04 17:04:41.362. INFO: EFSM.TestGenerator.RandomGenerator.WORK.TEST(BEHAVIORAL)_0: the guarded action has been enabled successfully. Input vector: {events: {CLK}; transaction: {RESET = false}}
2015.03.04 17:04:41.362. INFO: EFSM.TestGenerator.RandomGenerator.WORK.TEST(BEHAVIORAL)_0: the EFSM has been reset successfully
2015.03.04 17:04:41.363. INFO: EFSM.Simulator.WORK.TEST(BEHAVIORAL)_0: processing the events: {CLK}
2015.03.04 17:04:41.363. INFO: EFSM.Simulator.WORK.TEST(BEHAVIORAL)_0: input dump: {RESET = false}
2015.03.04 17:04:41.383. INFO: EFSM.Simulator.WORK.TEST(BEHAVIORAL)_0: initialising the simulator. The reset guarded action: {{CLK}: {predicate: (NOT RESET)}->{{assignment: C[0:0] := false; assignment: C[0:0] := false}}}
2015.03.04 17:04:41.403. INFO: EFSM.Simulator.WORK.TEST(BEHAVIORAL)_0: the reset guard is enabled
2015.03.04 17:15:05.161. ERROR: The exception has been encountered: java.lang.IllegalArgumentException: Uncompatible data types: LOGIC_BOOLEAN vs (MAP LOGIC_INTEGER LOGIC_BOOLEAN)
    at ru.ispras.retrascope.engine.efsm.simulator.EfsmSimulator.computeExpression(EfsmSimulator.java:733)
    at ru.ispras.retrascope.engine.efsm.simulator.EfsmSimulator.executeAssignment(EfsmSimulator.java:678)
    at ru.ispras.retrascope.engine.efsm.simulator.EfsmSimulator.executeAction(EfsmSimulator.java:577)
    at ru.ispras.retrascope.engine.efsm.simulator.EfsmSimulator.initialise(EfsmSimulator.java:301)
    at ru.ispras.retrascope.engine.efsm.simulator.EfsmSimulator.processEvents(EfsmSimulator.java:260)
    at ru.ispras.retrascope.engine.efsm.generator.test.RandomGenerator.submitVector(RandomGenerator.java:133)
    at ru.ispras.retrascope.engine.efsm.generator.test.EfsmTestGenerator.start(EfsmTestGenerator.java:200)
    at ru.ispras.retrascope.engine.efsm.generator.test.EfsmTestGenerator.start(EfsmTestGenerator.java:66)
    at ru.ispras.retrascope.basis.Engine.start(Engine.java:200)
    at ru.ispras.retrascope.basis.ToolChain.start(ToolChain.java:106)
    at ru.ispras.retrascope.basis.Engine.start(Engine.java:200)
    at ru.ispras.retrascope.Retrascope$Run.start(Retrascope.java:116)
    at ru.ispras.retrascope.Retrascope.main(Retrascope.java:333)
    at ru.ispras.retrascope.Retrascope.main(Retrascope.java:355)
    at ru.ispras.retrascope.util.VhdlUtilTest.runRetrascope(VhdlUtilTest.java:148)
    at ru.ispras.retrascope.util.VhdlUtilTest.runVhdl(VhdlUtilTest.java:73)
    at ru.ispras.retrascope.util.HdlUtilTest.runVhdl(HdlUtilTest.java:94)
    at ru.ispras.retrascope.engine.efsm.generator.test.EfsmTestGeneratorVhdlTestCase.generate(EfsmTestGeneratorVhdlTestCase.java:32)

The cause is that when x is array of type MAP(x,y), the x[i] element of array x is of type y, not of type MAP(x,y).

History

#1

Updated by Sergey Smolov over 5 years ago

The Retrascope project now is not in consistent state for this bug to be successfully resolved.
In fact, the processing of STD_LOGIC/STD_ULOGIC variables is implemented but not committed.
When this job will be done, the bug status will be raised to Normal.

#2

Updated by Sergey Smolov over 5 years ago

  • Subject changed from [efsm][simulator] computeExpression -> LOGIC_BOOLEAN vs (MAP LOGIC_INTEGER LOGIC_BOOLEAN) to computeExpression -> LOGIC_BOOLEAN vs (MAP LOGIC_INTEGER LOGIC_BOOLEAN)
  • Category set to Engine (Simulator)
#3

Updated by Sergey Smolov over 4 years ago

  • Target version changed from 0.1 to 0.2
#4

Updated by Sergey Smolov almost 4 years ago

  • Detected in build changed from svn to master
#5

Updated by Sergey Smolov about 3 years ago

  • Status changed from New to Rejected

The tool does not fall on this design. The bug is rejected.

Also available in: Atom PDF