Project

General

Profile

Feature #5553

Реализовать правило (AND (NOT (EQ expr const1)) (EQ expr const2)) => (EQ expr const2), если const2 != const1

Added by Igor Melnichenko almost 6 years ago. Updated over 5 years ago.

Status:
Closed
Priority:
Normal
Category:
Transformer
Target version:
Start date:
01/13/2015
Due date:
% Done:

100%

Estimated time:
Published in build:

Description

expr - выражение.
const1, const2 - константы.

History

#1

Updated by Artem Kotsynyak over 5 years ago

  • Status changed from New to Feedback
  • % Done changed from 0 to 100

r780 needs review, may introduce regressions in client code.

#2

Updated by Alexander Kamkin over 5 years ago

  • Subject changed from [transformer][ruleset] реализовать правило (AND (NOT (EQ expr const1)) (EQ expr const2)) => (EQ expr const2), если const2 != const1 to Реализовать правило (AND (NOT (EQ expr const1)) (EQ expr const2)) => (EQ expr const2), если const2 != const1
  • Category set to Transformer
#3

Updated by Artem Kotsynyak over 5 years ago

  • Status changed from Feedback to Resolved

Mark the issue as resolved due to lack of negative feedback.

#4

Updated by Igor Melnichenko over 5 years ago

  • Status changed from Resolved to Verified
#5

Updated by Artem Kotsynyak over 5 years ago

  • Status changed from Verified to Closed

Also available in: Atom PDF