Project

General

Profile

Bug #5536

[efsm][generator][test] EfsmTestGeneratorVhdlTestCase -> java.lang.RuntimeException: Unexpected simulation result

Added by Sergey Smolov over 4 years ago. Updated over 4 years ago.

Status:
Closed
Priority:
Normal
Category:
-
Target version:
Start date:
12/26/2014
Due date:
% Done:

100%

Estimated time:
Detected in build:
svn
Platform:
Published in build:
20141230

Description

генератор тестов запускался на дизайне b02

[error-log]

java.lang.RuntimeException: java.lang.RuntimeException: Unexpected simulation result. Expected state (AND (AND (GREATEREQ STATO 0) (LESSEQ STATO 6)) (AND (AND (AND (AND (AND (NOT (EQ STATO 0)) (NOT (EQ STATO 1))) (NOT (EQ STATO 2))) (NOT (EQ STATO 3))) (NOT (EQ STATO 4))) (EQ STATO 5))). Current state: (AND (AND (GREATEREQ STATO 0) (LESSEQ STATO 6)) (AND (NOT (EQ STATO 0)) (EQ STATO 1)))
at ru.ispras.retrascope.engine.efsm.generator.test.EfsmTestGenerator.generateSequenceDirectionally(EfsmTestGenerator.java:575)
at ru.ispras.retrascope.engine.efsm.generator.test.EfsmTestGenerator.start(EfsmTestGenerator.java:369)
at ru.ispras.retrascope.engine.efsm.generator.test.EfsmTestGenerator.start(EfsmTestGenerator.java:77)
at ru.ispras.retrascope.basis.Engine.start(Engine.java:199)
at ru.ispras.retrascope.basis.ToolChain.start(ToolChain.java:106)
at ru.ispras.retrascope.basis.Engine.start(Engine.java:199)
at ru.ispras.retrascope.Retrascope$Run.start(Retrascope.java:116)
at ru.ispras.retrascope.Retrascope.main(Retrascope.java:326)
at ru.ispras.retrascope.Retrascope.main(Retrascope.java:347)
at ru.ispras.retrascope.util.VhdlUtilTest.runRetrascope(VhdlUtilTest.java:148)
at ru.ispras.retrascope.util.VhdlUtilTest.runVhdl(VhdlUtilTest.java:73)
at ru.ispras.retrascope.util.HdlUtilTest.runVhdl(HdlUtilTest.java:94)
at ru.ispras.retrascope.engine.efsm.generator.test.EfsmTestGeneratorVhdlTestCase.generate(EfsmTestGeneratorVhdlTestCase.java:32)
Caused by: java.lang.RuntimeException: Unexpected simulation result. Expected state (AND (AND (GREATEREQ STATO 0) (LESSEQ STATO 6)) (AND (AND (AND (AND (AND (NOT (EQ STATO 0)) (NOT (EQ STATO 1))) (NOT (EQ STATO 2))) (NOT (EQ STATO 3))) (NOT (EQ STATO 4))) (EQ STATO 5))). Current state: (AND (AND (GREATEREQ STATO 0) (LESSEQ STATO 6)) (AND (NOT (EQ STATO 0)) (EQ STATO 1)))
at ru.ispras.retrascope.engine.efsm.generator.test.EfsmTestGenerator.generateSequenceDirectionally(EfsmTestGenerator.java:554)

[/error-log]

History

#1

Updated by Igor Melnichenko over 4 years ago

  • Status changed from New to Resolved
  • % Done changed from 0 to 100
#2

Updated by Sergey Smolov over 4 years ago

  • Status changed from Resolved to Verified
#3

Updated by Sergey Smolov over 4 years ago

  • Status changed from Verified to Closed
  • Published in build set to 20141230

Also available in: Atom PDF