Project

General

Profile

Bug #5020

Add new Test на узле Requirements дает ошибку

Added by Viktoria Kopach over 5 years ago. Updated over 4 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Start date:
07/03/2014
Due date:
% Done:

100%

Estimated time:
Detected in build:
0.16.200
Platform:
Windows x64
Published in build:
0.16.201

Description

На узле Requairements вызываем меню Add new test.
В Error log view появляется ошибка:

eclipse.buildId=4.3.2.M20140221-1700
java.version=1.7.0_45
java.vendor=Oracle Corporation
BootLoader constants: OS=win32, ARCH=x86, WS=win32, NL=ru_RU
Framework arguments: -product org.eclipse.platform.ide -eclipse.keyring C:\Users\nicke\q7workspace\.metadata\.plugins\org.eclipse.pde.core\Requality_Kepler/secure_storage
Command-line arguments: -product org.eclipse.platform.ide -data C:\Users\nicke\q7workspace/../aut-Requality_Kepler -dev file:C:/Users/nicke/q7workspace/.metadata/.plugins/org.eclipse.pde.core/Requality_Kepler/dev.properties -os win32 -ws win32 -arch x86 -consoleLog -eclipse.keyring C:\Users\nicke\q7workspace\.metadata\.plugins\org.eclipse.pde.core\Requality_Kepler/secure_storage

Error
Thu Jul 03 13:07:12 GMT+04:00 2014
Unhandled event loop exception

org.eclipse.e4.core.di.InjectionException: java.lang.NullPointerException
at org.eclipse.e4.core.internal.di.MethodRequestor.execute(MethodRequestor.java:63)
at org.eclipse.e4.core.internal.di.InjectorImpl.invokeUsingClass(InjectorImpl.java:243)
at org.eclipse.e4.core.internal.di.InjectorImpl.invoke(InjectorImpl.java:224)
at org.eclipse.e4.core.contexts.ContextInjectionFactory.invoke(ContextInjectionFactory.java:132)
at org.eclipse.e4.core.commands.internal.HandlerServiceHandler.execute(HandlerServiceHandler.java:167)
at org.eclipse.core.commands.Command.executeWithChecks(Command.java:499)
at org.eclipse.core.commands.ParameterizedCommand.executeWithChecks(ParameterizedCommand.java:508)
at org.eclipse.e4.core.commands.internal.HandlerServiceImpl.executeHandler(HandlerServiceImpl.java:213)
at org.eclipse.e4.ui.workbench.renderers.swt.HandledContributionItem.executeItem(HandledContributionItem.java:850)
at org.eclipse.e4.ui.workbench.renderers.swt.HandledContributionItem.handleWidgetSelection(HandledContributionItem.java:743)
at org.eclipse.e4.ui.workbench.renderers.swt.HandledContributionItem.access$7(HandledContributionItem.java:727)
at org.eclipse.e4.ui.workbench.renderers.swt.HandledContributionItem$4.handleEvent(HandledContributionItem.java:662)
at org.eclipse.swt.widgets.EventTable.sendEvent(EventTable.java:84)
at org.eclipse.swt.widgets.Widget.sendEvent_aroundBody2(Widget.java:1057)
at org.eclipse.swt.widgets.Widget$AjcClosure3.run(Widget.java:1)
at com.xored.tesla.recording.aspects.RecordingAspect.ajc$around$com_xored_tesla_recording_aspects_RecordingAspect$2$2f127892proceed(RecordingAspect.aj:1)
at com.xored.tesla.recording.aspects.RecordingAspect.ajc$around$com_xored_tesla_recording_aspects_RecordingAspect$2$2f127892(RecordingAspect.aj:118)
at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1055)
at org.eclipse.swt.widgets.Display.runDeferredEvents(Display.java:4170)
at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:3759)
at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine$9.run(PartRenderingEngine.java:1113)
at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:332)
at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine.run(PartRenderingEngine.java:997)
at org.eclipse.e4.ui.internal.workbench.E4Workbench.createAndRunUI(E4Workbench.java:140)
at org.eclipse.ui.internal.Workbench$5.run(Workbench.java:611)
at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:332)
at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Workbench.java:567)
at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.java:150)
at org.eclipse.ui.internal.ide.application.IDEApplication.start(IDEApplication.java:124)
at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:196)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:110)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:79)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:354)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:181)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
at java.lang.reflect.Method.invoke(Unknown Source)
at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:636)
at org.eclipse.equinox.launcher.Main.basicRun(Main.java:591)
at org.eclipse.equinox.launcher.Main.run(Main.java:1450)
at org.eclipse.equinox.launcher.Main.main(Main.java:1426)
Caused by: java.lang.NullPointerException
at com.unitesk.reqcoverage.tests.NewTestGenerator.isEnabled(NewTestGenerator.java:41)
at com.unitesk.requality.tests.TestDialogProvider.fireTestCreation(TestDialogProvider.java:61)
at com.unitesk.reqcoverage.handlers.CreateNewTest.execute(CreateNewTest.java:21)
at org.eclipse.ui.internal.handlers.HandlerProxy.execute_aroundBody0(HandlerProxy.java:290)
at org.eclipse.ui.internal.handlers.HandlerProxy$AjcClosure1.run(HandlerProxy.java:1)
at com.xored.tesla.recording.aspects.WorkbenchRecordingAspect.ajc$around$com_xored_tesla_recording_aspects_WorkbenchRecordingAspect$2$943c663bproceed(WorkbenchRecordingAspect.aj:1)
at com.xored.tesla.recording.aspects.WorkbenchRecordingAspect.ajc$around$com_xored_tesla_recording_aspects_WorkbenchRecordingAspect$2$943c663b(WorkbenchRecordingAspect.aj:67)
at org.eclipse.ui.internal.handlers.HandlerProxy.execute(HandlerProxy.java:283)
at org.eclipse.ui.internal.handlers.E4HandlerProxy.execute(E4HandlerProxy.java:90)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
at java.lang.reflect.Method.invoke(Unknown Source)
at org.eclipse.e4.core.internal.di.MethodRequestor.execute(MethodRequestor.java:56)
... 41 more

Associated revisions

Revision 3597 (diff)
Added by Denis Kildishev over 5 years ago

fixes: #5020; Adds recognition of "Requirements" in node by User Visible name find mechanism

Revision c6b8c19e (diff)
Added by Denis Kildishev over 5 years ago

fixes: #5020; Adds recognition of "Requirements" in node by User Visible name find mechanism

git-svn-id: https://forge.ispras.ru/svn/reqdb/trunk/requality@3597 f558eac1-05b1-4da7-9ed5-5050e8a619d6

Revision 3597 (diff)
Added by Denis Kildishev over 5 years ago

fixes: #5020; Adds recognition of "Requirements" in node by User Visible name find mechanism

History

#1

Updated by Denis Kildishev over 5 years ago

  • Status changed from New to Resolved
  • % Done changed from 0 to 100

Applied in changeset r3597.

#2

Updated by Denis Kildishev over 5 years ago

  • Published in build set to 0.16.201
#3

Updated by Alexey Khoroshilov over 5 years ago

  • Target version set to 0.16
#4

Updated by Viktoria Kopach over 5 years ago

  • Status changed from Resolved to Verified
#5

Updated by Alexey Khoroshilov over 4 years ago

  • Status changed from Verified to Closed

Also available in: Atom PDF