Project

General

Profile

Feature #3314

135: msleep and some other functions take time periods in milliseconds, not jiffies

Added by Mikhail Mandrykin about 7 years ago. Updated almost 7 years ago.

Status:
Closed
Priority:
Normal
Start date:
07/31/2012
Due date:
% Done:

0%

Estimated time:
Published in build:

Description

We should check parameters of some functions from linux/delay.h and linux/sched.h (and maybe some other headers) for being previously converted with the use of msecs_to_jiffies or jiffies_to_msecs functions.
Sample bugfix commit id: d6b6225.


Related issues

Is duplicate of Linux Kernel Safety RuleDB - Feature #2732: 103: Check that msleep isn't called with a value in jiffiesResolved04/10/2012

Actions

History

#1

Updated by Vadim Mutilin about 7 years ago

merge it with rule 103

#2

Updated by Mikhail Mandrykin almost 7 years ago

  • Status changed from New to Closed

Duplicates Issue #2732

Also available in: Atom PDF