Project

General

Profile

Bug #3246

After moving common aspects into separate files 'NULL' macro isn't substituted

Added by Mikhail Mandrykin over 7 years ago. Updated about 7 years ago.

Status:
Closed
Priority:
Normal
Category:
-
Start date:
07/20/2012
Due date:
% Done:

0%

Estimated time:
Detected in build:
svn
Platform:
Published in build:

Description

Using 'NULL' macro in 100_1a rule model aspect lead to BLAST failure with the following message:

/home/schrodinger/benchmark/cpachecker/work/current--X--packed_drivers/100_1a--test-start_tty.tar.bz2--X--defaultlinux-3.4.4--X--
100_1a/linux-3.4.4/csd_deg_dscv/11/dscv_tempdir/rule-instrumentor/100_1a/common-model/ldv_common_model.c:11: Error: Cannot resolve variable NULL.
/home/schrodinger/benchmark/cpachecker/work/current--X--packed_drivers/100_1a--test-start_tty.tar.bz2--X--defaultlinux-3.4.4--X--100_1a/linux
-3.4.4/csd_deg_dscv/11/dscv_tempdir/rule-instrumentor/100_1a/common-model/ldv_common_model.c:19: Error: Cannot resolve variable NULL.

Previously the model was tested with no BLAST failure.

History

#1

Updated by Evgeny Novikov over 7 years ago

  • Status changed from New to Feedback

Can you provide source code of the file that has such the problem?
IMHO, the problem is that your common model hasn't necessary include files (which may be included before because of a common model was placed after driver source code).

#2

Updated by Mikhail Mandrykin over 7 years ago

  • Status changed from Feedback to Resolved

Yes, the reason was I didn't include necessary files (the same as were previously included in the .aspect file) in the common model.

#3

Updated by Evgeny Novikov over 7 years ago

Issue author should close the issue if he or she founds it to be resolved.

#4

Updated by Mikhail Mandrykin over 7 years ago

  • Status changed from Resolved to Verified
#5

Updated by Mikhail Mandrykin over 7 years ago

  • Status changed from Verified to Closed
#6

Updated by Evgeny Novikov about 7 years ago

  • Project changed from Linux Driver Verification to C Instrumentation Framework
  • Category deleted (15)

Also available in: Atom PDF