Project

General

Profile

Bug #3013

Ошибки при редактировании атрибутов STRING, FLOAT и BOOL

Added by Viktoria Kopach over 8 years ago. Updated about 5 years ago.

Status:
Closed
Priority:
Low
Assignee:
-
Category:
-
Target version:
Start date:
06/13/2012
Due date:
% Done:

100%

Estimated time:
Detected in build:
0.13.155
Platform:
Windows x64
Published in build:
0.15.197

Description

1. Меняем вручную json требования. Указываем атрибут типа FLOAT со значением, например, 0.5 (то есть с правильным значением).
2. Открываем проект, открываем свойства этого требования, дважды кликаем на этом атрибуте (хотим редактировать его), появляется окно с ошибкой.
null
Error
Wed Jun 13 19:32:16 MSK 2012
Problems occurred when invoking code from plug-in: "org.eclipse.jface".

java.lang.ClassCastException: java.lang.Float cannot be cast to java.lang.String
at com.unitesk.requality.eclipse.views.properties.AttributesPanel$5.doubleClick(AttributesPanel.java:284)
at org.eclipse.jface.viewers.StructuredViewer$1.run(StructuredViewer.java:845)
at org.eclipse.core.runtime.SafeRunner.run(SafeRunner.java:42)
at org.eclipse.ui.internal.JFaceUtil$1.run(JFaceUtil.java:49)
at org.eclipse.jface.util.SafeRunnable.run(SafeRunnable.java:175)
at org.eclipse.jface.viewers.StructuredViewer.fireDoubleClick(StructuredViewer.java:843)
at org.eclipse.jface.viewers.StructuredViewer.handleDoubleSelect(StructuredViewer.java:1134)
at org.eclipse.jface.viewers.StructuredViewer$4.widgetDefaultSelected(StructuredViewer.java:1246)
at org.eclipse.jface.util.OpenStrategy.fireDefaultSelectionEvent(OpenStrategy.java:249)
at org.eclipse.jface.util.OpenStrategy.access$0(OpenStrategy.java:246)
at org.eclipse.jface.util.OpenStrategy$1.handleEvent(OpenStrategy.java:307)
at org.eclipse.swt.widgets.EventTable.sendEvent(EventTable.java:84)
at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1053)
at org.eclipse.swt.widgets.Display.runDeferredEvents(Display.java:4165)
at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:3754)
at org.eclipse.ui.internal.Workbench.runEventLoop(Workbench.java:2701)
at org.eclipse.ui.internal.Workbench.runUI(Workbench.java:2665)
at org.eclipse.ui.internal.Workbench.access$4(Workbench.java:2499)
at org.eclipse.ui.internal.Workbench$7.run(Workbench.java:679)
at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:332)
at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Workbench.java:668)
at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.java:149)
at org.eclipse.ui.internal.ide.application.IDEApplication.start(IDEApplication.java:123)
at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:196)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:110)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:79)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:344)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:179)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
at java.lang.reflect.Method.invoke(Unknown Source)
at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:622)
at org.eclipse.equinox.launcher.Main.basicRun(Main.java:577)
at org.eclipse.equinox.launcher.Main.run(Main.java:1410)

То же самое происходит для всех "правильных атрибутов". То есть для тех, у которых значение соответствует типу (кроме STRING). Для остальных редактирование атрибутов работает без ошибок.

Проект, на котором можно посмотреть и проверить, здесь http://forge.ispras.ru/projects/reqdb/repository/show/sandbox/regression_testing/verifyCheckersForAttributes

Associated revisions

Revision 3476 (diff)
Added by Denis Kildishev over 6 years ago

#3013; adds special editor for LIST type of attributes, changes the way how BOOL, FLOAT, INT are handled in editor(adds parsing). This helps open editor for the most of cases. Known bug - when editing one of two equals items like "a" and "a", editor changes always first one. It seems to be bug of standard Text Editor

Revision 914791da (diff)
Added by Denis Kildishev over 6 years ago

#3013; adds special editor for LIST type of attributes, changes the way how BOOL, FLOAT, INT are handled in editor(adds parsing). This helps open editor for the most of cases. Known bug - when editing one of two equals items like "a" and "a", editor changes always first one. It seems to be bug of standard Text Editor

git-svn-id: https://forge.ispras.ru/svn/reqdb/trunk/requality@3476 f558eac1-05b1-4da7-9ed5-5050e8a619d6

Revision 3476 (diff)
Added by Denis Kildishev over 6 years ago

#3013; adds special editor for LIST type of attributes, changes the way how BOOL, FLOAT, INT are handled in editor(adds parsing). This helps open editor for the most of cases. Known bug - when editing one of two equals items like "a" and "a", editor changes always first one. It seems to be bug of standard Text Editor

History

#1

Updated by Viktoria Kopach over 8 years ago

  • Description updated (diff)
#2

Updated by Denis Kildishev over 6 years ago

  • Status changed from New to Resolved
  • % Done changed from 0 to 100

Applied in changeset r3476.

#3

Updated by Alexey Khoroshilov over 6 years ago

  • Target version set to 0.16
#4

Updated by Denis Kildishev over 6 years ago

  • Published in build set to 0.15.197
#5

Updated by Viktoria Kopach over 6 years ago

  • Status changed from Resolved to Verified
#6

Updated by Alexey Khoroshilov about 5 years ago

  • Status changed from Verified to Closed

Also available in: Atom PDF