Project

General

Profile

Actions

Feature #10944

closed

Allocate external data for platform_device.dev.platform_data

Added by Evgeny Novikov 10 months ago. Updated 10 months ago.

Status:
Closed
Priority:
High
Category:
Environment models
Target version:
Start date:
09/16/2021
Due date:
% Done:

0%

Estimated time:
Published in build:

Description

After fixing #10930 we started to get quite many false alarms due to fixed allocation of memory for platform_device of platform drivers. These false alarms are related with using data from undefined objects pointed by platform_device.dev.platform_data. We cannot develop good models for all related device drivers from which this data comes, so, I suggest to allocate external data for that pointer within environment models.


Related issues 1 (0 open1 closed)

Blocks Klever - Bug #10930: Fix memory allocation via $ALLOC in EMG specificationsClosedIlja Zakharov09/09/2021

Actions
Actions #1

Updated by Evgeny Novikov 10 months ago

  • Related to Bug #10930: Fix memory allocation via $ALLOC in EMG specifications added
Actions #2

Updated by Evgeny Novikov 10 months ago

  • Related to deleted (Bug #10930: Fix memory allocation via $ALLOC in EMG specifications)
Actions #3

Updated by Evgeny Novikov 10 months ago

  • Blocks Bug #10930: Fix memory allocation via $ALLOC in EMG specifications added
Actions #4

Updated by Evgeny Novikov 10 months ago

  • Assignee changed from Ilja Zakharov to Evgeny Novikov

I will try to implement that feature. I expect that the most complicated part will be testing.

Actions #5

Updated by Evgeny Novikov 10 months ago

  • Status changed from New to Resolved

I did that directly in branch fix-alloc and it did help to return back discovering of Unsafe - Timeout for 2 target bugs. Let's see on extended testing results since this issue as well as #10930 are rather crucial.

Actions #6

Updated by Evgeny Novikov 10 months ago

  • Status changed from Resolved to Closed

CI tests passed after some tuning (there were not strictly negative regressions while there were several positive ones), so, I merged the branch to master in 620be6b12.

Actions

Also available in: Atom PDF