Project

General

Profile

Bug #10735

Could not update development OpenStack instances

Added by Evgeny Novikov about 2 months ago. Updated about 2 months ago.

Status:
Closed
Priority:
Immediate
Category:
Deployment
Target version:
Start date:
03/02/2021
Due date:
% Done:

0%

Estimated time:
Detected in build:
git
Platform:
Published in build:

Description

At the moment nobody can update development OpenStack instances of Klever using deployment scripts. Corresponding errors look like:

2021-03-02 16:37:22 (utils.py:041) INFO> Execute command "rsync -asz --del -e ssh -o StrictHostKeyChecking=no -i ../ldv-meta/deployment/cloud.ispras/cloud.key /tmp/tmpsbcvv1i8/klever debian@10.100.151.157:/home/debian/" 
cannot delete non-empty directory: klever/bridge/bridge/__pycache__
cannot delete non-empty directory: klever/bridge/bridge/management/commands/__pycache__
...
2021-03-02 16:37:23 (ssh.py:084) INFO> Close SSH session to instance "joker-klever-production-x2" (IP: 10.100.151.157)
Traceback (most recent call last):
  File "/home/novikov/work/klever/venv/bin/klever-deploy-openstack", line 11, in <module>
    load_entry_point('klever', 'console_scripts', 'klever-deploy-openstack')()
  File "/home/novikov/work/klever/klever/deploys/openstack/__init__.py", line 108, in main
    getattr(OSKleverInstance(args, logger), args.action)()
  File "/home/novikov/work/klever/klever/deploys/openstack/instance.py", line 153, in update
    'update of Klever instance'
  File "/home/novikov/work/klever/klever/deploys/openstack/copy.py", line 46, in __enter__
    self.ssh.rsync(klever_copy, '~/')
  File "/home/novikov/work/klever/klever/deploys/openstack/ssh.py", line 154, in rsync
    stderr=subprocess.DEVNULL
  File "/home/novikov/work/klever/klever/deploys/utils.py", line 62, in execute_cmd
    subprocess.check_call(args, **kwargs)
  File "/usr/local/python3-klever/lib/python3.7/subprocess.py", line 363, in check_call
    raise CalledProcessError(retcode, cmd)
subprocess.CalledProcessError: Command '('rsync', '-asz', '--del', '-e', 'ssh -o StrictHostKeyChecking=no -i ../ldv-meta/deployment/cloud.ispras/cloud.key', '/tmp/tmpsbcvv1i8/klever', 'debian@10.100.151.157:/home/debian/')' returned non-zero exit status 23.

The issue is caused by 514b7e7 that is necessary from the another point of view.

#1

Updated by Evgeny Novikov about 2 months ago

  • Status changed from New to Closed

I fixed this in 4299b0134 to the master branch and backported the fix to v3.0-stable.

Also available in: Atom PDF